<!DOCTYPE html>
<!--[if lt IE 7]> <html lang="en-US" class="no-js ie6"> <![endif]-->
<!--[if IE 7]>    <html lang="en-US" class="no-js ie7"> <![endif]-->
<!--[if IE 8]>    <html lang="en-US" class="no-js ie8"> <![endif]-->
<!--[if IE 9]>    <html lang="en-US" class="no-js ie9"> <![endif]-->
<!--[if (gt IE 9)|!(IE)]><!--> <html lang="en-US" class="no-js"> <!--<![endif]-->
<head>
<style id="" media="all">@font-face {
  font-family: 'Josefin Sans';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/josefinsans/v17/Qw3PZQNVED7rKGKxtqIqX5E-AVSJrOCfjY46_DjQbMZhKg.ttf) format('truetype');
}
@font-face {
  font-family: 'Oswald';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/oswald/v40/TK3_WkUHHAIjg75cFRf3bXL8LICs1_FvsUZiYA.ttf) format('truetype');
}
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/roboto/v29/KFOmCnqEu92Fr1Mu4mxP.ttf) format('truetype');
}
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3057451736576335",
    enable_page_level_ads: true
  });
</script>
<meta name="google-site-verification" content="JH747qvihYfCLMAhl3_ajUANMbGpb5h7XbuotKZorRQ" />
<meta name="google-site-verification" content="S0x4cgaY9fKrtguUegqjdN_FRD0pVnIWDbMDYw6u5eA" />
<meta name="google-site-verification" content="eiCgNixAzZIPEyBsKAH6g-U-19QEDZGrZ6J15fzTGuY" />
<meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">
<title>
		Murder case moves forward against alleged shooter in July homicide on Bell Springs Road &bull; The Mendocino Voice | Mendocino County, CAThe Mendocino Voice | Mendocino County, CA	</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://mendovoice.com/xmlrpc.php" />
<script>
			function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://mendovoice.com/wp-content/uploads/2018/06/Josefin-Masthead-768.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://mendovoice.com/wp-content/uploads/2018/06/Josefin-Masthead-980-1.png';
				} else {
					header_img = 'https://mendovoice.com/wp-content/uploads/2018/06/20th-century-Masthead-Autumn-2019-colors-6-2.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();
		</script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Murder case moves forward against alleged shooter in July homicide on Bell Springs Road &bull; The Mendocino Voice | Mendocino County, CA</title>
<meta name="description" content="Bail has been reduced from $1 million to $800K and Judge Keith Faulder has recused himself from the case." />
<link rel="canonical" href="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Murder case moves forward against alleged shooter in July homicide on Bell Springs Road &bull; The Mendocino Voice | Mendocino County, CA" />
<meta property="og:description" content="Bail has been reduced from $1 million to $800K and Judge Keith Faulder has recused himself from the case." />
<meta property="og:url" content="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/" />
<meta property="og:site_name" content="The Mendocino Voice | Mendocino County, CA" />
<meta property="article:publisher" content="https://www.facebook.com/MendoVoice/" />
<meta property="article:published_time" content="2021-10-28T06:02:50+00:00" />
<meta property="article:modified_time" content="2021-10-28T06:02:55+00:00" />
<meta property="og:image" content="https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="480" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@TheMendoVoice" />
<meta name="twitter:site" content="@TheMendoVoice" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Dave Brooksher" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="2 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mendovoice.com/#organization","name":"The Mendocino Voice","url":"https://mendovoice.com/","sameAs":["https://www.facebook.com/MendoVoice/","https://www.instagram.com/mendovoice/","https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw","https://twitter.com/TheMendoVoice"],"logo":{"@type":"ImageObject","@id":"https://mendovoice.com/#logo","inLanguage":"en-US","url":"https://mendovoice.com/wp-content/uploads/2018/02/Favicon-Prime.png","contentUrl":"https://mendovoice.com/wp-content/uploads/2018/02/Favicon-Prime.png","width":152,"height":152,"caption":"The Mendocino Voice"},"image":{"@id":"https://mendovoice.com/#logo"}},{"@type":"WebSite","@id":"https://mendovoice.com/#website","url":"https://mendovoice.com/","name":"The Mendocino Voice | Mendocino County, CA","description":"Useful news, for all of Mendocino County, CA","publisher":{"@id":"https://mendovoice.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://mendovoice.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#primaryimage","inLanguage":"en-US","url":"https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ.jpg","contentUrl":"https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ.jpg","width":640,"height":480,"caption":"OSCAR ALVAREZ RUIZ, photo from the MCSO booking logs."},{"@type":"WebPage","@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#webpage","url":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/","name":"Murder case moves forward against alleged shooter in July homicide on Bell Springs Road &bull; The Mendocino Voice | Mendocino County, CA","isPartOf":{"@id":"https://mendovoice.com/#website"},"primaryImageOfPage":{"@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#primaryimage"},"datePublished":"2021-10-28T06:02:50+00:00","dateModified":"2021-10-28T06:02:55+00:00","description":"Bail has been reduced from $1 million to $800K and Judge Keith Faulder has recused himself from the case.","breadcrumb":{"@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/"]}]},{"@type":"BreadcrumbList","@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://mendovoice.com/"},{"@type":"ListItem","position":2,"name":"Murder case moves forward against alleged shooter in July homicide on Bell Springs Road"}]},{"@type":"NewsArticle","@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#article","isPartOf":{"@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#webpage"},"author":{"@id":"https://mendovoice.com/#/schema/person/54170b99a200971d672829ee0e2ac28b"},"headline":"Murder case moves forward against alleged shooter in July homicide on Bell Springs Road","datePublished":"2021-10-28T06:02:50+00:00","dateModified":"2021-10-28T06:02:55+00:00","mainEntityOfPage":{"@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#webpage"},"wordCount":404,"commentCount":0,"publisher":{"@id":"https://mendovoice.com/#organization"},"image":{"@id":"https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#primaryimage"},"thumbnailUrl":"https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ.jpg","keywords":["crime","homicide","mendocino county superior court","murder"],"articleSection":["Police &amp; Courts"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#respond"]}]},{"@type":"Person","@id":"https://mendovoice.com/#/schema/person/54170b99a200971d672829ee0e2ac28b","name":"Dave Brooksher","url":"https://mendovoice.com/author/david-brooksher/"}]}</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Mendocino Voice | Mendocino County, CA &raquo; Feed" href="https://mendovoice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Mendocino Voice | Mendocino County, CA &raquo; Comments Feed" href="https://mendovoice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Mendocino Voice | Mendocino County, CA &raquo; Murder case moves forward against alleged shooter in July homicide on Bell Springs Road Comments Feed" href="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/feed/" />
<script id="mendo-ready">
			window.advanced_ads_ready=function(e,a){a=a||"complete";var d=function(e){return"interactive"===a?"loading"!==e:"complete"===e};d(document.readyState)?e():document.addEventListener("readystatechange",(function(a){d(a.target.readyState)&&e()}),{once:"interactive"===a})},window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[];		</script>
<link rel='stylesheet' id='wp-block-library-css' href='https://mendovoice.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css' href='https://mendovoice.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://mendovoice.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='awsm-ead-public-css' href='https://mendovoice.com/wp-content/plugins/embed-any-document/css/embed-public.min.css?ver=2.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='widgetopts-styles-css' href='https://mendovoice.com/wp-content/plugins/widget-options/assets/css/widget-options.css' type='text/css' media='all' />
<link rel='stylesheet' id='largo-stylesheet-css' href='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/css/style.min.css?ver=0.5.5.4' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slick-css' href='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/lib/navis-slideshows/vendor/slick/slick.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='navis-slides-css' href='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/lib/navis-slideshows/css/slides.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='your-theme-css' href='https://mendovoice.com/wp-content/themes/Largo-Sample-Child-Theme-master/css/child.min.css?ver=5.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://mendovoice.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://mendovoice.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://mendovoice.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.29.1' id='advanced-ads-advanced-js-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/js/load-more-posts.min.js?ver=0.5.5.4' id='load-more-posts-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/js/modernizr.custom.js?ver=0.5.5.4' id='largo-modernizr-js'></script>

<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-83666118-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["mendovoice.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-83666118-1");
</script>

<link rel="https://api.w.org/" href="https://mendovoice.com/wp-json/" /><link rel="alternate" type="application/json" href="https://mendovoice.com/wp-json/wp/v2/posts/746227" /><link rel='shortlink' href='https://mendovoice.com/?p=746227' />
<link rel="alternate" type="application/json+oembed" href="https://mendovoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmendovoice.com%2F2021%2F10%2Fmurder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mendovoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmendovoice.com%2F2021%2F10%2Fmurder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.44.0" /><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<style type='text/css'>img#wpstats{display:none}</style>
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@themendovoice">
<meta property="og:title" content="Murder case moves forward against alleged shooter in July homicide on Bell Springs Road" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/" />
<meta property="og:description" content="Bail has been reduced from $1 million to $800K and Judge Keith Faulder has recused himself from the case. " />
<meta name="description" content="Bail has been reduced from $1 million to $800K and Judge Keith Faulder has recused himself from the case. " />
<meta property="og:site_name" content="The Mendocino Voice | Mendocino County, CA" /><meta property="og:image" content="https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ.jpg" /><link rel="apple-touch-icon" href="https://mendovoice.com/wp-content/uploads/2018/06/Favicon-Autumn-2019-colors-5.jpg" /><link rel="shortcut icon" href="https://mendovoice.com/wp-content/uploads/2018/06/Favicon-Autumn-2019-colors-6.jpg" /><meta name="news_keywords" content="Police &amp; Courts, crime, homicide, mendocino county superior court, murder"><meta name="original-source" content="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/" /><meta name="syndication-source" content="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/" /><meta name="standout" content="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/" /> <script>
			    var _gaq = _gaq || [];
										    _gaq.push(
					["largo._setAccount", "UA-17578670-4"],
					["largo._setCustomVar", 1, "SiteName", "The Mendocino Voice | Mendocino County, CA"],
					["largo._setDomainName", "mendovoice.com"],
					["largo._setAllowLinker", true],
					["largo._trackPageview"]
				);

			    (function() {
				    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
<link rel="icon" href="https://mendovoice.com/wp-content/uploads/2018/06/cropped-Favicon-Autumn-2019-colors-5-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://mendovoice.com/wp-content/uploads/2018/06/cropped-Favicon-Autumn-2019-colors-5-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mendovoice.com/wp-content/uploads/2018/06/cropped-Favicon-Autumn-2019-colors-5-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://mendovoice.com/wp-content/uploads/2018/06/cropped-Favicon-Autumn-2019-colors-5-270x270.jpg" />
<style type="text/css" id="wp-custom-css">
			h5 img {
    display: none;
}

/*
* — Body Background Color —
*/
body {
	background:#f7f7f7;
}

.btn.btn-primary {

    margin-bottom: 20px;

}

h2.widget-title.widget-heading {
    font-size: 17px;
    line-height: 10px;
    font-weight: bold;
    font-family: josefin sans;
    font-style: italic;
    margin-bottom: 10px;
    
    padding-top: 10px;
}

#homepage-featured .sub-stories p {
    font-size: 14.672px;
    margin-bottom: 12px;
}
#site-header {
	margin: 0px;
}

/*
* — Adjust Homepage Widget Featured Images —
*/

.widget img.attachment-large, .widget img.attachment-medium {
    padding: 0 0 .66em;
    width: 100%;
		height: 250px
}

.home a {
	color: #000;
}
.widget h5 {
    margin-bottom: .2em;
    font-size: 15px;
}

.alert-wrapper {
    background: 0 0;
    border: none;
    margin: 0px;
}
#alert-container {
    padding: 1em 0 0 1em;
    margin: 0px;
    background-color: #FFD900;
}

.alert-wrapper a {
	color: #2275bb !important;
}

#site-footer a {
	color:#fff !important
}

img.icon_title {
    float: right;
}
.home img.icon_title {
    display: none;
}

h1.entry-title, h2 {
    font-size: 34px;
}

aside#largo-donate-widget-3 {
    border: 1px solid #e3e3e3;
    padding: 20px 20px;
    background: #f5f5f5;
	border-top:2px solid #333;
}

#sidebar .widget {
    padding: 0 0 0 0px;
}
.widgettitle {
    font-size: 19px;
}
.footer-bg {
    background-color: #2d4e5b;
}

aside.scaip.scaip-1 {
    clear: both;
    margin: auto;
    width: 50%;
}
aside.scaip.scaip-2 {
    clear: both;
    margin: auto;
    width: 50%;
}

#homepage-featured .top-story p {
    font-size: 14px;
    margin-bottom: 12px;
    font-family: Robot;
}

h1.entry-title, h2 {
    font-size: 34px;
    font-family: Oswald;
}


.stories h2.entry-title {
    font-size: 32px;
    margin-bottom: 8px;
    line-height: 1.1;
    font-family: oswald;
}

.stories .entry-content p {
    font-family: roboto;
}

/*
* — Navigation Text —
*/

.navbar .nav>li>a {
    color: #484848;
    font-family: oswald;
		font-size:22px;
}

/*
* — Headline Link Color for Cats —
*/
.stories h2.entry-title a {
    color: #333 !important;
}

.widget p, .widget ul {
    font-family: roboto;
}

#homepage-featured .sub-stories p {
    font-family: Roboto;
}

#homepage-featured .top-story p {
    font-size: 18px;
    margin-bottom: 12px;
    font-family: Roboto;
}



#homepage-featured .sub-stories h3 {
    font-size: 16px;
    margin-bottom: 6px;
    line-height: 1.2;
    font-family: oswald;
    letter-spacing: 1px;
}

.dropdown-menu li {
	font-family: Oswald;
}

/*
* — In Post Ad Size For Mobile Devices —
*/
@media only screen and (max-width: 600px) {
aside.scaip.scaip-2 {
    clear: both;
    margin: auto;
    width: 100%;

	}
}
@media only screen and (max-width: 600px) {	
	aside.scaip.scaip-1 {
    clear: both;
    margin: auto;
    width: 100%;
}
}

.breadcrumbs span div img{
	display: none;
}
.home-featured-widget-area {
    margin-top: 20px;
    border-top: 1px solid #ddd;
    padding-top: 11px;
}

.entry-title img {
    margin-top: 20px;
}

.footer-credit-padding-inn-logo-missing {
display: none;
}		</style>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-746227 single-format-standard aa-prefix-mendo- classic">
<div id="top"></div>
<div class="global-nav-bg">
<div class="global-nav">
<nav id="top-nav" class="span12">
<span class="visuallyhidden">
<a href="#main" title="Skip to content">Skip to content</a>
</span>
<ul id="menu-global-navigation" class="menu"><li id="menu-item-10348" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10348"><a href="https://mendovoice.com/about/">About Us</a></li>
<li id="menu-item-149323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149323"><a href="https://mendovoice.com/about/">Contact</a></li>
<li id="menu-item-10349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10349"><a href="https://mendovoice.com/advertise/">Advertise</a></li>
<li id="menu-item-10347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10347"><a href="https://mendovoice.com/tips/">Tips &#038; Submissions</a></li>
<li id="menu-item-10350" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10350"><a href="/cdn-cgi/l/email-protection#0a63646c654a676f646e657c6563696f24696567"><span class="__cf_email__" data-cfemail="660f080009260b0308020910090f05034805090b">[email&#160;protected]</span></a></li>
</ul> <div class="nav-right">
<ul id="header-social" class="social-icons visible-desktop">
<li><a href="https://www.facebook.com/MendoVoice/" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/themendovoice" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/mendovoice/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://mendovoice.com/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li> </ul>
<div class="donate-btn"><a href="https://mendovoice.com/membership/"><i class="icon-heart"></i>Support us, become a member!</a></div> 
<div id="header-search">
<form class="form-search" role="search" method="get" action="https://mendovoice.com/">
<div class="input-append">
<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">GO</button>
</div>
</form>
</div>

</div>
</nav>
</div> 
</div> 
<div id="page" class="hfeed clearfix">
<div class="sticky-nav-wrapper nocontent">
<div class="sticky-nav-holder">
<div class="sticky-nav-container">
<nav id="sticky-nav" class="sticky-navbar navbar clearfix">
<div class="container">
<div class="nav-right">
<ul id="header-social" class="social-icons visible-desktop">
<li><a href="https://www.facebook.com/MendoVoice/" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/themendovoice" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/mendovoice/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://mendovoice.com/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li> </ul>
<ul id="header-extras">
<li class="donate">
<a class="donate-link" href="https://mendovoice.com/membership/">
<span><i class="icon-heart"></i>Support us, become a member!</span>
</a>
</li> <li id="sticky-nav-search">
<a href="#" class="toggle">
<i class="icon-search" title="Search" role="button"></i>
</a>
<form class="form-search" role="search" method="get" action="https://mendovoice.com/">
<div class="input-append">
<span class="text-input-wrapper">
<input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" />
</span>
<button type="submit" class="search-submit btn">Go</button>
</div>
</form>
</li>
<li>

<a class="btn btn-navbar toggle-nav-bar" title="More">
<div class="bars">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</div>
</a>
</li>
</ul>
</div>

<div class="nav-left">
<ul>
<li class="home-icon"><a href="https://mendovoice.com/"><img src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo" alt="logo"></a></li>
</ul>
</div>


<div class="nav-shelf">
<ul class="nav">
<li class="home-icon">
<a href="https://mendovoice.com/">
<img src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo" alt="logo"> </a>
</li>
<li id="menu-item-156624" class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown menu-item-156624"><a href="https://mendovoice.com/prominence/homepage-featured/" class="dropdown-toggle">News <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li id="menu-item-69410" class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-69410"><a href="https://mendovoice.com/prominence/homepage-featured/">Top News</a></li>
<li id="menu-item-454707" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454707"><a href="https://mendovoice.com/tag/community-info/">Notices &#038; Announcements</a></li>
<li id="menu-item-62664" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62664"><a href="https://mendovoice.com/latest-news/">Latest News</a></li>
<li id="menu-item-354" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-354"><a href="https://mendovoice.com/category/police-courts/">Police &amp; Courts</a></li>
<li id="menu-item-10468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10468"><a href="https://mendovoice.com/category/food-farm/">Food &#038; Ag</a></li>
<li id="menu-item-454691" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454691"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li>
<li id="menu-item-11391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11391"><a href="https://mendovoice.com/category/education/">Education</a></li>
<li id="menu-item-11390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11390"><a href="https://mendovoice.com/category/business/">Business &#038; Economy</a></li>
<li id="menu-item-11392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11392"><a href="https://mendovoice.com/category/health/">Health</a></li>
<li id="menu-item-10467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10467"><a href="https://mendovoice.com/category/environment-natural-resources/">Environment</a></li>
<li id="menu-item-406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-406"><a href="https://mendovoice.com/category/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-10795" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-10795"><a href="https://mendovoice.com/tag/community-info/" class="dropdown-toggle">Announcements <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li id="menu-item-454706" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454706"><a href="https://mendovoice.com/tag/community-info/">Events &#038; Announcements</a></li>
<li id="menu-item-185668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-185668"><a href="https://mendovoice.com/category/arts-culture/">Arts &amp; Culture <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li id="menu-item-454708" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454708"><a href="https://mendovoice.com/tag/opinion">Opinions &#038; Voices</a></li>
</ul>
</li>
<li id="menu-item-185669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185669"><a href="https://mendovoice.com/category/food-farm/">Food &amp; Farming</a></li>
<li id="menu-item-185670" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185670"><a href="https://mendovoice.com/category/health/">Health</a></li>
<li id="menu-item-454705" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454705"><a href="https://mendovoice.com/tag/opinion">Columns &#038; Opinion</a></li>
</ul>
</li>
<li id="menu-item-632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-632"><a href="https://mendovoice.com/category/fire-emergency/" class="dropdown-toggle">Fire &amp; Emergency <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li id="menu-item-454699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454699"><a href="https://mendovoice.com/tag/calfire/">Cal Fire</a></li>
<li id="menu-item-454700" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454700"><a href="https://mendovoice.com/tag/earthquake/">Earthquakes</a></li>
<li id="menu-item-454695" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454695"><a href="https://mendovoice.com/series/2020-fire-season/">Fire Season 2020</a></li>
<li id="menu-item-454693" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454693"><a href="https://mendovoice.com/series/2019-fire-season/">Fire Season 2019</a></li>
<li id="menu-item-454690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454690"><a href="https://mendovoice.com/category/weather/">Weather</a></li>
</ul>
</li>
<li id="menu-item-6330" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6330"><a href="https://mendovoice.com/category/traffic-roads/">Roads</a></li>
<li id="menu-item-355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-355"><a href="https://mendovoice.com/category/politics-government/" class="dropdown-toggle">Politics <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li id="menu-item-454694" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454694"><a href="https://mendovoice.com/series/2020-election/">Election 2020</a></li>
<li id="menu-item-454692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454692"><a href="https://mendovoice.com/tag/board-of-supervisors/">Board of Supervisors</a></li>
<li id="menu-item-380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-380"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li>
<li id="menu-item-10466" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10466"><a href="https://mendovoice.com/tag/opinion">Opinion</a></li>
</ul>
</li>
<li id="menu-item-454689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-454689"><a href="https://mendovoice.com/category/health/" class="dropdown-toggle">Health <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li id="menu-item-454688" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454688"><a href="https://mendovoice.com/series/coronavirus-covid-19/">Coronavirus</a></li>
</ul>
</li>
<li id="menu-item-9790" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9790"><a href="https://mendovoice.com/membership/">Membership</a></li>
<li id="menu-item-430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-430"><a href="https://mendovoice.com/advertise/" class="dropdown-toggle">Ads <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li id="menu-item-454678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454678"><a href="https://mendovoice.com/advertise/">Advertise with Mendo Voice</a></li>
<li id="menu-item-454679" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454679"><a href="https://mendovoice.com/advertise/fire-coverage-community-partners-2019/">Fire Coverage Community Partners, 2019</a></li>
</ul>
</li>
<li id="menu-item-436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-436"><a href="https://mendovoice.com/about/" class="dropdown-toggle">About Us <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li id="menu-item-149318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149318"><a href="https://mendovoice.com/about/">Contact Us</a></li>
<li id="menu-item-113862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113862"><a href="https://mendovoice.com/about/">About Us</a></li>
<li id="menu-item-444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444"><a href="https://mendovoice.com/about/staff/">Staff</a></li>
<li id="menu-item-435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435"><a href="https://mendovoice.com/tips/">Tips &#038; Submissions</a></li>
<li id="menu-item-156647" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156647"><a href="https://mendovoice.com/commenting-and-letter-to-editor-policy/">Commenting Policy</a></li>
</ul>
</li>
<li id="menu-item-454696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454696"><a href="https://mendovoice.com/category/weather/">Weather</a></li>
<li class="donate">
<a class="donate-link" href="https://mendovoice.com/membership/">
<span>Support us, become a member!</span>
</a>
</li> <li class="menu-item menu-item-has-childen dropdown">
<a href="javascript:void(0);" class="dropdown-toggle">Global Navigation <b class="caret"></b>
</a>
<ul id="menu-global-navigation-1" class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10348"><a href="https://mendovoice.com/about/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149323"><a href="https://mendovoice.com/about/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10349"><a href="https://mendovoice.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10347"><a href="https://mendovoice.com/tips/">Tips &#038; Submissions</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10350"><a href="/cdn-cgi/l/email-protection#f79e999198b79a9299939881989e9492d994989a"><span class="__cf_email__" data-cfemail="620b0c040d220f070c060d140d0b01074c010d0f">[email&#160;protected]</span></a></li>
</ul> </li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</div>
<header id="site-header" class="clearfix nocontent" itemscope itemtype="http://schema.org/Organization">
<h2 class="visuallyhidden">
<a itemprop="url" href="https://mendovoice.com/">
<span class="sitename" itemprop="name">The Mendocino Voice | Mendocino County, CA</span>
<span class="tagline" itemprop="description"> - Useful news, for all of Mendocino County, CA</span>
</a>
</h2>
<a itemprop="url" href="https://mendovoice.com/"><img class="header_img" src="" alt="" /></a><meta itemprop="logo" content="https://mendovoice.com/wp-content/uploads/2018/06/Favicon-Autumn-2019-colors-5.jpg" /></header>
<header class="print-header nocontent">
<p>
<strong>The Mendocino Voice | Mendocino County, CA</strong>
(https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/)
</p>
</header>
<nav id="main-nav" class="navbar clearfix">
<div class="navbar-inner">
<div class="container">
<div class="nav-shelf">
<ul class="nav">
<li class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown menu-item-156624"><a href="https://mendovoice.com/prominence/homepage-featured/" class="dropdown-toggle">News <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-69410"><a href="https://mendovoice.com/prominence/homepage-featured/">Top News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454707"><a href="https://mendovoice.com/tag/community-info/">Notices &#038; Announcements</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62664"><a href="https://mendovoice.com/latest-news/">Latest News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-354"><a href="https://mendovoice.com/category/police-courts/">Police &amp; Courts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10468"><a href="https://mendovoice.com/category/food-farm/">Food &#038; Ag</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454691"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11391"><a href="https://mendovoice.com/category/education/">Education</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11390"><a href="https://mendovoice.com/category/business/">Business &#038; Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11392"><a href="https://mendovoice.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10467"><a href="https://mendovoice.com/category/environment-natural-resources/">Environment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-406"><a href="https://mendovoice.com/category/weather/">Weather</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-10795"><a href="https://mendovoice.com/tag/community-info/" class="dropdown-toggle">Announcements <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454706"><a href="https://mendovoice.com/tag/community-info/">Events &#038; Announcements</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-185668"><a href="https://mendovoice.com/category/arts-culture/">Arts &amp; Culture <i class="icon-arrow-right"></i></a>
<ul class="dropdown-menu sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454708"><a href="https://mendovoice.com/tag/opinion">Opinions &#038; Voices</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185669"><a href="https://mendovoice.com/category/food-farm/">Food &amp; Farming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185670"><a href="https://mendovoice.com/category/health/">Health</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454705"><a href="https://mendovoice.com/tag/opinion">Columns &#038; Opinion</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-632"><a href="https://mendovoice.com/category/fire-emergency/" class="dropdown-toggle">Fire &amp; Emergency <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454699"><a href="https://mendovoice.com/tag/calfire/">Cal Fire</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454700"><a href="https://mendovoice.com/tag/earthquake/">Earthquakes</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454695"><a href="https://mendovoice.com/series/2020-fire-season/">Fire Season 2020</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454693"><a href="https://mendovoice.com/series/2019-fire-season/">Fire Season 2019</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454690"><a href="https://mendovoice.com/category/weather/">Weather</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6330"><a href="https://mendovoice.com/category/traffic-roads/">Roads</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-355"><a href="https://mendovoice.com/category/politics-government/" class="dropdown-toggle">Politics <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454694"><a href="https://mendovoice.com/series/2020-election/">Election 2020</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454692"><a href="https://mendovoice.com/tag/board-of-supervisors/">Board of Supervisors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-380"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10466"><a href="https://mendovoice.com/tag/opinion">Opinion</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-454689"><a href="https://mendovoice.com/category/health/" class="dropdown-toggle">Health <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454688"><a href="https://mendovoice.com/series/coronavirus-covid-19/">Coronavirus</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9790"><a href="https://mendovoice.com/membership/">Membership</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-430"><a href="https://mendovoice.com/advertise/" class="dropdown-toggle">Ads <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454678"><a href="https://mendovoice.com/advertise/">Advertise with Mendo Voice</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454679"><a href="https://mendovoice.com/advertise/fire-coverage-community-partners-2019/">Fire Coverage Community Partners, 2019</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-436"><a href="https://mendovoice.com/about/" class="dropdown-toggle">About Us <b class="caret"></b></a></a>
<ul class="dropdown-menu">
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149318"><a href="https://mendovoice.com/about/">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113862"><a href="https://mendovoice.com/about/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444"><a href="https://mendovoice.com/about/staff/">Staff</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435"><a href="https://mendovoice.com/tips/">Tips &#038; Submissions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156647"><a href="https://mendovoice.com/commenting-and-letter-to-editor-policy/">Commenting Policy</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454696"><a href="https://mendovoice.com/category/weather/">Weather</a></li>
</ul>
</div>
</div>
</div>
</nav>
<div id="main" class="row-fluid clearfix">
<div id="content" class="span8" role="main">
<article id="post-746227" class="hnews item post-746227 post type-post status-publish format-standard has-post-thumbnail hentry category-police-courts tag-crime tag-homicide tag-mendocino-county-superior-court tag-murder prominence-homepage-featured prominence-homepage-featured-2 prominence-top-story prominence-top-story-2 featured-media featured-media-image" itemscope itemtype="http://schema.org/Article">
<header>
<h1 class="entry-title mush" itemprop="headline">Murder case moves forward against alleged shooter in July homicide on Bell Springs Road</h1>
<h5 class="byline"><span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author"> <a class="url fn n" href="https://mendovoice.com/author/david-brooksher/" title="Read All Posts By Dave Brooksher" rel="author">Dave Brooksher</a><span class="job-title"><span class="comma">,</span> Staff Writer</span></span></span><span class="sep"> |</span> <time class="entry-date updated dtstamp pubdate" datetime="2021-10-27T23:02:50-07:00"><span class="time-ago">6 seconds ago</span></time></h5>
<div class="largo-follow post-social clearfix"><span class="more-social-links">
<a class="popover-toggle" href="#"><i class="icon-plus"></i><span class="hidden-phone">More</span></a>
<span class="popover">
<ul>
<li><a href="https://mendovoice.com/category/mendo/"><i class="icon-link"></i> <span>More on Mendocino</span></a></li>
<li><a href="https://mendovoice.com/category/mendo/feed/"><i class="icon-rss"></i> <span>Subscribe to Mendocino</span></a></li>
</ul>
</span>
</span></div>
<meta itemprop="description" content="Bail has been reduced from $1 million to $800K and Judge Keith Faulder has recused himself from the case. 
Share this:TwitterFacebook" />
<meta itemprop="datePublished" content="2021-10-27T23:02:50-07:00" />
<meta itemprop="dateModified" content="2021-10-27T23:02:55-07:00" />
<meta itemprop="image" content="https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ-140x140.jpg" />
</header><div class="breadcrumbs" typeof="BreadcrumbList" vocab="http://schema.org/">
<div class="hero is-image ">
<img width="640" height="480" src="https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ.jpg" class="attachment-full size-full wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ.jpg 640w, https://mendovoice.com/wp-content/uploads/2021/07/OSCAR-ALVAREZ-RUIZ-336x252.jpg 336w" sizes="(max-width: 640px) 100vw, 640px" /> <p class="wp-caption-text">OSCAR ALVAREZ RUIZ, photo from the MCSO booking logs.</p>
</div>
<div class="entry-content clearfix" itemprop="articleBody">
<p>MENDOCINO Co., 10/27/21 — The defendant charged with fatally shooting 27-year-old Edgar Alejandro Becerra-Almaraz at a cannabis operation on Bell Springs Road in July has been held to answer for the crime, according to court documents, meaning that a preliminary hearing was held and Judge Keith Faulder found sufficient evidence to take the case to trial. Oscar Alvarez Ruiz, who was 23 at the time of his arrest this summer, may also be offered a plea deal.&nbsp;</p>
<p>Deputies with the Mendocino County Sheriff Office <a href="https://mendovoice.com/2021/07/man-fatally-shot-on-bell-spring-road-early-friday-morning/">responded to the 59000 block of Bell Springs Road</a>, near U.S. Highway 101, on report of gunshots around 1:45 a.m. July 23. Becerra-Almaraz was found with a gunshot wound to the leg when deputies arrived on scene just before 3 a.m., and Ruiz was allegedly seen fleeing downhill. A search ensued, lasting roughly three hours and involving assistance from a California Highway Patrol aircraft. Another individual was also detained, but that person was not charged with a crime and their name has not been publicized.</p>
<p>Ruiz was charged July 27, and entered a plea of not guilty on Aug. 5. Meanwhile, he remains in custody on $800,000 bail — down from $1 million after a motion by the defense. A preliminary hearing was held Oct. 15 before Judge Keith Faulder and Ruiz was held to answer on all counts, including murder with special allegations that he used a handgun, as well as being in possession of cocaine at the time of the crime. He is scheduled to return to court at 9 a.m. this Friday, Oct. 29 for another arraignment hearing, but that will take place in the courtroom of Presiding Judge Ann Moorman.&nbsp;&nbsp;</p><div class="mendo-inline-placement" style="text-align: center; " id="mendo-837365043"><div class="mendo-adlabel">Advertisements</div><div data-advadstrackid="724559" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-159545084"><a href="https://www.adventisthealth.org/coronavirus/vaccine/" rel="noopener" class="adv-link" target="_blank"><img loading="lazy" src="https://mendovoice.com/wp-content/uploads/2021/07/211087_AHUV-AHMC-AHHM_VaccineCampaign_300x250.jpg" alt="" class="no-lazyload" width="300" height="250" /></a></div></div><br style="clear: both; display: block; float: none;" />
<p>Faulder granted a <a href="https://portal-camendocino.tylertech.cloud/Portal/DocumentViewer/Index/MIMp1Aqs7yPTqM_WxvNxsW7MDuG6fQcS7FKeKuLH8UfnYJZej2QMSdyk3Q4oM618d-Jp-RNM6DVDI3oo0PkHBgwLRH7CQ4fL3T9MtT8iQmQ1?caseNum=21CR01414&amp;docType=Public&amp;docName=Disqualification%20pursuant%20to%20CCP170.6%20filed%20by%20PD%20-%20FAULDER&amp;docTypeId=3&amp;p=0">motion</a> from Ruiz’s attorneys with the Mendocino County Public Defender asking him to recuse himself under California Civil Procedure code 170.6 arguing Faulder is “prejudiced against the defendant or the interests of the defendant so that he cannot or believes he cannot have a fair and impartial hearing before said judge.” Public Defender Jeffrey Aaron responded to a request for comment on his client’s behalf, saying the specific details of the alleged prejudice is privileged information under state law.</p>
<p>PREVIOUSLY:</p><div class="mendo-inline-repeating" style="text-align: center; " id="mendo-580756443"><div class="mendo-adlabel">Advertisements</div><div data-advadstrackid="722897" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-149883481"><a href="https://www.sonomawater.org/current-water-supply-levels" rel="noopener" class="adv-link" target="_blank"><img loading="lazy" src="https://mendovoice.com/wp-content/uploads/2021/07/Sonoma_water_simplified_ad.jpeg" alt="" class="no-lazyload" width="300" height="250" /></a></div></div>
<p><a href="https://mendovoice.com/2021/07/man-fatally-shot-on-bell-spring-road-early-friday-morning/">7/23/21 — Man fatally shot on Bell Springs Road early Friday morning</a></p>
<p><a href="https://mendovoice.com/2021/07/suspect-in-bell-springs-road-homicide-identified/">7/30/21 — Victim in Bell Springs Road homicide identified; accused suspect returns to court next week</a>&nbsp;</p>
<p><a href="https://mendovoice.com/2021/08/bail-set-at-1-million-for-alleged-shooter-in-bell-springs-road-homicide/">8/11/21 — Bail set at $1 million for alleged shooter in Bell Springs Road homicide</a></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-746227" class="share-twitter sd-button share-icon" href="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-746227" class="share-facebook sd-button share-icon" href="https://mendovoice.com/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div> </div>
<footer class="post-meta bottom-meta">
</footer>
</article>
<div class="article-bottom nocontent"><aside id="media_image-4" class="widget widget-1 odd default hidden-phone widget widget_media_image clearfix"><img width="664" height="57" src="https://mendovoice.com/wp-content/uploads/2020/12/Bottom-article-line-3.png" class="image wp-image-542716  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://mendovoice.com/wp-content/uploads/2020/12/Bottom-article-line-3.png 664w, https://mendovoice.com/wp-content/uploads/2020/12/Bottom-article-line-3-336x29.png 336w" sizes="(max-width: 664px) 100vw, 664px" /></aside><aside class="widget widget-2 even default widget mendo-widget clearfix"><div data-advadstrackid="723356" data-advadstrackbid="1" data-advadsredirect="" id="mendo-1366404167"><img loading="lazy" src="https://mendovoice.com/wp-content/uploads/2021/07/Fire-sponsorship-graphic.jpeg" alt="" class="no-lazyload" width="457" height="177" /></div></aside><aside class="widget widget-3 odd default widget mendo-widget clearfix"><div data-advadstrackid="723370" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-1595107086"><a href="https://www.adventisthealth.org/mendocino-county/orthopedics/?hcmacid=a0i3m00000BfSZu&#038;utm_campaign=NCR_AH_MENDO_ORTHO_F21&#038;utm_medium=Radio&#038;utm_content=RD_NCR_AH_MENDO_ORTHO_F21%20https://www.adventisthealth.org/mendocino-county/orthopedics/?hcmacid=a0i3m00000BfSZu&#038;utm_campaign=NCR_AH_MENDO_ORTHO_F21&#038;utm_medium=Radio&#038;utm_content=RD_NCR_AH_MENDO_ORTHO_F21%20https://www.adventisthealth.org/mendocino-county/orthopedics/?hcmacid=a0i3m00000BfSZu&#038;utm_campaign=NCR_AH_MENDO_ORTHO_F21&#038;utm_medium=Radio&#038;utm_content=RD_NCR_AH_MENDO_ORTHO_F21%20https://www.adventisthealth.org/mendocino-county/orthopedics/?hcmacid=a0i3m00000BfSZu&#038;utm_campaign=NCR_AH_MENDO_ORTHO_F21&#038;utm_medium=Radio&#038;utm_content=RD_NCR_AH_MENDO_ORTHO_F21%20https://www.adventisthealth.org/mendocino-county/orthopedics/?hcmacid=a0i3m00000BfSZu&#038;utm_campaign=NCR_AH_MENDO_ORTHO_F21&#038;utm_medium=Radio&#038;utm_content=RD_NCR_AH_MENDO_ORTHO_F21%20https://www.adventisthealth.org/mendocino-county/orthopedics/?hcmacid=a0i3m00000BfSZu&#038;utm_campaign=NCR_AH_MENDO_ORTHO_F21&#038;utm_medium=Radio&#038;utm_content=RD_NCR_AH_MENDO_ORTHO_F21%20https://www.adventisthealth.org/mendocino-county/orthopedics/?hcmacid=a0i3m00000BfSZu&#038;utm_campaign=NCR_AH_MENDO_ORTHO_F21&#038;utm_medium=Radio&#038;utm_content=RD_NCR_AH_MENDO_ORTHO_F21" rel="noopener" class="adv-link" target="_blank"><img loading="lazy" src="https://mendovoice.com/wp-content/uploads/2021/07/Health-sponsorship-graphic.jpeg" alt="" class="no-lazyload" width="456" height="147" /></a></div></aside><aside id="largo-donate-widget-3" class="widget widget-4 even default widget largo-donate clearfix"><h3 class="widgettitle">Do you find this news service valuable?</h3>
<p>Help maintain it by becoming a member.</p>
<a class="btn btn-primary" href="https://mendovoice.com/membership/#single-contribution">Become a member!</a>
</aside><aside id="largo-donate-widget-7" class="widget widget-5 odd default widget largo-donate clearfix"><h3 class="widgettitle">Ok, did you enjoy this article but no others?</h3>
<p>That&#039;s fine, consider a one time contribution to keep local journalism going.</p>
<a class="btn btn-primary" href="https://mendovoice.com/membership/">Contribute</a>
</aside><aside id="largo-recent-posts-widget-36" class="widget widget-6 even default widget largo-recent-posts clearfix"><h3 class="widgettitle">Read more local news:</h3><ul><li> <a href="https://mendovoice.com/2021/06/how-do-you-get-information-about-your-community-in-mendocino-county/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/06/1Wih9xwYJOzdAbCv51c-iHA-60x60.jpeg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/06/1Wih9xwYJOzdAbCv51c-iHA-60x60.jpeg 60w, https://mendovoice.com/wp-content/uploads/2021/06/1Wih9xwYJOzdAbCv51c-iHA-140x140.jpeg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/06/how-do-you-get-information-about-your-community-in-mendocino-county/">How do you get information about your community in Mendocino County? </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/weekend-storm-drenches-mendocino-coast-but-fails-to-end-drought/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/10/IMG_5197-60x60.jpg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/10/IMG_5197-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2021/10/IMG_5197-140x140.jpg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/weekend-storm-drenches-mendocino-coast-but-fails-to-end-drought/">Weekend storm drenches Mendocino coast, but fails to end drought </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/covid-19-in-nursing-homes-miller-report-for-october-26-21-column/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/02/Dr.-William-Miller-from-a-Zoom-interview-December-2020.-60x60.jpg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/02/Dr.-William-Miller-from-a-Zoom-interview-December-2020.-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2021/02/Dr.-William-Miller-from-a-Zoom-interview-December-2020.-140x140.jpg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/covid-19-in-nursing-homes-miller-report-for-october-26-21-column/">Covid-19 in nursing homes: Miller Report for October 26, &#8217;21 (column) </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/fast-acting-county-workers-scramble-to-keep-toxic-debris-from-wildfires-out-of-russian-river-during-rainstorm/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/10/CCC-staking-down-wattles-60x60.jpg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/10/CCC-staking-down-wattles-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2021/10/CCC-staking-down-wattles-140x140.jpg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/fast-acting-county-workers-scramble-to-keep-toxic-debris-from-wildfires-out-of-russian-river-during-rainstorm/">Fast-acting county workers scramble to keep toxic debris from wildfires out of Russian River during rainstorm </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/search-underway-for-humboldt-county-hunter-missing-in-the-covelo-area/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/10/247251228_247433167424183_4418561493558381277_n-60x60.jpg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/10/247251228_247433167424183_4418561493558381277_n-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2021/10/247251228_247433167424183_4418561493558381277_n-140x140.jpg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/search-underway-for-humboldt-county-hunter-missing-in-the-covelo-area/">Search underway for Humboldt County hunter missing in the Covelo area </a>
</h5>
</li></ul></aside><aside class="widget widget-7 odd default widget mendo-widget clearfix"><div data-advadstrackid="722910" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-1577166155"><a href="https://www.adventisthealth.org/coronavirus/vaccine/" rel="noopener" class="adv-link" target="_blank"><img loading="lazy" src="https://mendovoice.com/wp-content/uploads/2021/07/Fall-21-leaderboard-AHUV-AHMC-AHHM_VaccineCampaign_728x90.jpg" alt="" class="no-lazyload" width="728" height="90" /></a></div></aside><aside id="largo-tag-list-widget-2" class="widget widget-8 even default widget largo-tag-list clearfix"> 
<div class="tags clearfix">
<h5>Filed Under:</h5>
<ul>
<li class="post-category-link"><a href="https://mendovoice.com/category/police-courts/" title="Read Articles in the Police &amp; Courts category">Police &amp; Courts</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/crime/" title="Read Articles tagged with: crime">crime</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/homicide/" title="Read Articles tagged with: homicide">homicide</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/mendocino-county-superior-court/" title="Read Articles tagged with: mendocino county superior court">mendocino county superior court</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/murder/" title="Read Articles tagged with: murder">murder</a></li> </ul>
</div>
</aside></div> <div id="comments" class="clearfix">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/10/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://mendovoice.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='746227' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="d739676c4f" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="14" /><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div>
</div>
<aside id="sidebar" class="span4 nocontent">
<div class="widget-area" role="complementary">
<aside class="widget widget-1 odd default widget mendo-widget clearfix"><div class="mendo-top-box" style="text-align: center; " id="mendo-1662369914"><div class="mendo-adlabel">Advertisements</div><div data-advadstrackid="724560" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-1611664787"><a href="https://www.adventisthealth.org/coronavirus/vaccine/" rel="noopener" class="adv-link" target="_blank"><img src="https://mendovoice.com/wp-content/uploads/2021/07/211087_AHUV-AHMC-AHHM_VaccineCampaign_300x250.jpg" alt="" class="no-lazyload" width="300" height="250" /></a></div></div></aside><aside id="largo-tag-list-widget-3" class="widget widget-2 even default widget largo-tag-list clearfix"> 
<div class="tags clearfix">
<h5>Filed Under:</h5>
<ul>
<li class="post-category-link"><a href="https://mendovoice.com/category/police-courts/" title="Read Articles in the Police &amp; Courts category">Police &amp; Courts</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/crime/" title="Read Articles tagged with: crime">crime</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/homicide/" title="Read Articles tagged with: homicide">homicide</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/mendocino-county-superior-court/" title="Read Articles tagged with: mendocino county superior court">mendocino county superior court</a></li><li class="post-tag-link"><a href="https://mendovoice.com/tag/murder/" title="Read Articles tagged with: murder">murder</a></li> </ul>
</div>
</aside><aside class="widget widget-3 odd default widget mendo-widget clearfix"><div class="mendo-half-page" style="text-align: center; " id="mendo-2101906971"><div data-advadstrackid="724849" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-671266752"><a href="https://mendocinocoastclinics.org/services/reproductive-health-obstetrics/" rel="noopener" class="adv-link" target="_blank"><img src="https://mendovoice.com/wp-content/uploads/2021/10/MCC-AD-Mendo-Voice-Prenatal-FINAL-1170x2340.jpg" alt="" class="no-lazyload" width="1250" height="2500" /></a></div></div></aside><aside id="custom_html-5" class="widget_text widget widget-4 even default widget widget_custom_html clearfix"><div class="textwidget custom-html-widget"><form class="PicoSignupForm">
<h4 style="color:red;">Get the news in your inbox
</h4>
<h5 style="color:black;"> Sign up for our headlines newsletter!
</h5>
<input type="email" placeholder="Email"><br>
<input type="submit" value="sign up">
</form></div></aside><aside class="widget widget-5 odd default widget mendo-widget clearfix"><div class="mendo-mid-box" id="mendo-2104159632"><div data-advadstrackid="724873" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-1198080763"><a href="https://www.adventisthealth.org/coronavirus/vaccine/" rel="noopener" class="adv-link" target="_blank"><img src="https://mendovoice.com/wp-content/uploads/2021/07/211087_AHUV-AHMC-AHHM_VaccineCampaign_300x250.jpg" alt="" class="no-lazyload" width="300" height="250" /></a></div></div></aside><aside id="largo-recent-posts-widget-22" class="widget widget-6 even default widget largo-recent-posts clearfix"><h3 class="widgettitle">Recent Articles</h3><ul><li> <a href="https://mendovoice.com/2021/10/u-s-forest-service-may-face-challenges-salvage-logging-august-complex-fire-footprint-in-mendocino-national-forest/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/10/cynthia-snyder-entomologist-examines-pine-bark-for-insects_51609323885_o-60x60.jpg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/10/cynthia-snyder-entomologist-examines-pine-bark-for-insects_51609323885_o-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2021/10/cynthia-snyder-entomologist-examines-pine-bark-for-insects_51609323885_o-140x140.jpg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/u-s-forest-service-may-face-challenges-salvage-logging-august-complex-fire-footprint-in-mendocino-national-forest/">U.S. Forest Service may face challenges salvage logging August Complex Fire footprint in Mendocino National Forest </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/lavish-weddings-are-back-but-vendors-are-struggling-with-costs-labor-shortages-and-tracking-down-tents/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2018/07/IMG_3560-60x60.jpg" class="left-align attachment-small wp-post-image" alt="Mendocino coast — KB Maxwell" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2018/07/IMG_3560-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2018/07/IMG_3560-140x140.jpg 140w, https://mendovoice.com/wp-content/uploads/2018/07/IMG_3560-250x250.jpg 250w, https://mendovoice.com/wp-content/uploads/2018/07/IMG_3560-65x65.jpg 65w, https://mendovoice.com/wp-content/uploads/2018/07/IMG_3560.jpg 320w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/lavish-weddings-are-back-but-vendors-are-struggling-with-costs-labor-shortages-and-tracking-down-tents/">Lavish weddings are back, but vendors are struggling with costs, labor shortages — and tracking down tents </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/the-atmospheric-river-is-here-storm-brings-potential-flooding-and-rising-rivers-to-mendocino-county-and-northern-ca/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/10/Drone-footage-of-the-Garcia-River-and-SR-1-from-October-24-2021photo-by-Mike-Nelson-60x60.jpg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/10/Drone-footage-of-the-Garcia-River-and-SR-1-from-October-24-2021photo-by-Mike-Nelson-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2021/10/Drone-footage-of-the-Garcia-River-and-SR-1-from-October-24-2021photo-by-Mike-Nelson-140x140.jpg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/the-atmospheric-river-is-here-storm-brings-potential-flooding-and-rising-rivers-to-mendocino-county-and-northern-ca/">The atmospheric river is here: SR 1 now open at the Garcia River, flooding, accidents and rising rivers in Mendocino County and Northern CA (updated 10/25) </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/cal-fire-mendocino-lifts-burn-permit-suspension-for-the-winter-season-wet-weather-trail-closures-in-mendocino-national-forest/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/09/Prescribed-fire-in-forest_LQuinnDavidson-60x60.jpg" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/09/Prescribed-fire-in-forest_LQuinnDavidson-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2021/09/Prescribed-fire-in-forest_LQuinnDavidson-140x140.jpg 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/cal-fire-mendocino-lifts-burn-permit-suspension-for-the-winter-season-wet-weather-trail-closures-in-mendocino-national-forest/">Cal Fire Mendocino lifts burn permit suspension for the winter season, wet weather trail closures in Mendocino National Forest </a>
</h5>
</li><li> <a href="https://mendovoice.com/2021/10/new-storm-series-to-bring-significant-rains-and-slew-of-wet-weather-changes-to-mendocino-county-and-northern-ca/"><img width="60" height="60" src="https://mendovoice.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-23-at-1.47.34-PM-60x60.png" class="left-align attachment-small wp-post-image" alt="" loading="lazy" srcset="https://mendovoice.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-23-at-1.47.34-PM-60x60.png 60w, https://mendovoice.com/wp-content/uploads/2021/10/Screen-Shot-2021-10-23-at-1.47.34-PM-140x140.png 140w" sizes="(max-width: 60px) 100vw, 60px" /></a>
<h5>
<a href="https://mendovoice.com/2021/10/new-storm-series-to-bring-significant-rains-and-slew-of-wet-weather-changes-to-mendocino-county-and-northern-ca/">New storm series to bring significant rains and slew of wet weather changes to Mendocino County and Northern CA </a>
</h5>
</li></ul></aside><aside id="largo-prev-next-post-links-widget-2" class="widget widget-7 odd default widget largo-prev-next-post-links clearfix">
<nav id="nav-below" class="pager post-nav clearfix">
<div class="previous"><a href="https://mendovoice.com/2021/10/weekend-storm-drenches-mendocino-coast-but-fails-to-end-drought/"><img class="thumb" src="https://mendovoice.com/wp-content/uploads/2021/10/IMG_5197-140x140.jpg" /><h5>Previous Article</h5><span class="meta-nav">Weekend storm drenches Mendocino coast, but fails to end drought</span></a></div> </nav>
</aside><aside class="widget widget-8 even default widget mendo-widget clearfix"><div class="mendo-bonus-box" style="text-align: center; " id="mendo-1361503558"><div data-advadstrackid="724844" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-803237843"><a href="https://motosportsofukiah.com/" rel="noopener" class="adv-link" target="_blank"><img src="https://mendovoice.com/wp-content/uploads/2021/07/ajJcWV_HondaMotorsportsUkiah_Box_Ad_004.jpeg" alt="" class="no-lazyload" width="300" height="250" /></a></div></div></aside><aside class="widget widget-9 odd default widget mendo-widget clearfix"><div class="mendo-top-box" style="text-align: center; " id="mendo-1640415911"><div class="mendo-adlabel">Advertisements</div><div data-advadstrackid="722915" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-900219911"><a href="https://mcfarm.org/" rel="noopener" class="adv-link" target="_blank"><img src="https://mendovoice.com/wp-content/uploads/2021/06/Ukiah-farmers-market-2-june-2021-e1622869597245.jpeg" alt="" class="no-lazyload" width="301" height="250" /></a></div></div></aside><aside class="widget widget-10 even default widget mendo-widget clearfix"><div class="mendo-top-box" style="text-align: center; " id="mendo-268063102"><div class="mendo-adlabel">Advertisements</div><div data-advadstrackid="724560" data-advadstrackbid="1" data-advadsredirect="" class="mendo-target" id="mendo-1490848558"><a href="https://www.adventisthealth.org/coronavirus/vaccine/" rel="noopener" class="adv-link" target="_blank"><img src="https://mendovoice.com/wp-content/uploads/2021/07/211087_AHUV-AHMC-AHHM_VaccineCampaign_300x250.jpg" alt="" class="no-lazyload" width="300" height="250" /></a></div></div></aside> </div>
</aside>
</div> 
</div>
<div class="footer-bg clearfix nocontent">
<footer id="site-footer">
<div id="supplementary" class="row-fluid _3col-default">
<div class="span3 widget-area" role="complementary">
<aside id="largo-about-widget-2" class="widget widget-1 odd default widget largo-about clearfix"><h3 class="widgettitle">About The Mendocino Voice</h3>
<p>The Mendocino Voice is a local, worker-owned, news service — based in, and covering Mendocino County, California. We believe in useful news for all of Mendocino.</p>
</aside></div>
<div class="span6 widget-area" role="complementary">
<aside id="categories-6" class="widget widget-1 odd default widget widget_categories clearfix"><h3 class="widgettitle">Categories</h3><form action="https://mendovoice.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select name='cat' id='cat' class='postform'>
<option value='-1'>Select Category</option>
<option class="level-0" value="78">Arts &amp; Culture</option>
<option class="level-0" value="47">Business &amp; Labor</option>
<option class="level-0" value="43">Cannabis</option>
<option class="level-0" value="60">Education</option>
<option class="level-0" value="50">Environment &amp; Natural Resources</option>
<option class="level-0" value="40">Fire &amp; Emergency</option>
<option class="level-0" value="48">Food &amp; Farming</option>
<option class="level-0" value="1770">Health</option>
<option class="level-0" value="4">Mendocino</option>
<option class="level-0" value="41">Police &amp; Courts</option>
<option class="level-0" value="38">Politics &amp; Government</option>
<option class="level-0" value="305">Roads &amp; Transportation</option>
<option class="level-0" value="85">Weather</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>
</aside></div>
<div class="span3 widget-area" role="complementary">
<div class="widget widget_search"><h2 class="widgettitle">Search This Site</h2><form class="form-search" role="search" method="get" action="https://mendovoice.com/">
<div class="input-append">
<input type="text" placeholder="Search" class="searchbox search-query" value="" name="s" /><button type="submit" name="search submit" class="search-submit btn">Go</button>
</div>
</form>
</div><div class="widget widget_archive"><h2 class="widgettitle">Browse Archives</h2> <label class="screen-reader-text" for="archives-dropdown--1">Browse Archives</label>
<select id="archives-dropdown--1" name="archive-dropdown">
<option value="">Select Month</option>
<option value='https://mendovoice.com/2021/10/'> October 2021 </option>
<option value='https://mendovoice.com/2021/09/'> September 2021 </option>
<option value='https://mendovoice.com/2021/08/'> August 2021 </option>
<option value='https://mendovoice.com/2021/07/'> July 2021 </option>
<option value='https://mendovoice.com/2021/06/'> June 2021 </option>
<option value='https://mendovoice.com/2021/05/'> May 2021 </option>
<option value='https://mendovoice.com/2021/04/'> April 2021 </option>
<option value='https://mendovoice.com/2021/03/'> March 2021 </option>
<option value='https://mendovoice.com/2021/02/'> February 2021 </option>
<option value='https://mendovoice.com/2021/01/'> January 2021 </option>
<option value='https://mendovoice.com/2020/12/'> December 2020 </option>
<option value='https://mendovoice.com/2020/11/'> November 2020 </option>
<option value='https://mendovoice.com/2020/10/'> October 2020 </option>
<option value='https://mendovoice.com/2020/09/'> September 2020 </option>
<option value='https://mendovoice.com/2020/08/'> August 2020 </option>
<option value='https://mendovoice.com/2020/07/'> July 2020 </option>
<option value='https://mendovoice.com/2020/06/'> June 2020 </option>
<option value='https://mendovoice.com/2020/05/'> May 2020 </option>
<option value='https://mendovoice.com/2020/04/'> April 2020 </option>
<option value='https://mendovoice.com/2020/03/'> March 2020 </option>
<option value='https://mendovoice.com/2020/02/'> February 2020 </option>
<option value='https://mendovoice.com/2020/01/'> January 2020 </option>
<option value='https://mendovoice.com/2019/12/'> December 2019 </option>
<option value='https://mendovoice.com/2019/11/'> November 2019 </option>
<option value='https://mendovoice.com/2019/10/'> October 2019 </option>
<option value='https://mendovoice.com/2019/09/'> September 2019 </option>
<option value='https://mendovoice.com/2019/08/'> August 2019 </option>
<option value='https://mendovoice.com/2019/07/'> July 2019 </option>
<option value='https://mendovoice.com/2019/06/'> June 2019 </option>
<option value='https://mendovoice.com/2019/05/'> May 2019 </option>
<option value='https://mendovoice.com/2019/04/'> April 2019 </option>
<option value='https://mendovoice.com/2019/03/'> March 2019 </option>
<option value='https://mendovoice.com/2019/02/'> February 2019 </option>
<option value='https://mendovoice.com/2019/01/'> January 2019 </option>
<option value='https://mendovoice.com/2018/12/'> December 2018 </option>
<option value='https://mendovoice.com/2018/11/'> November 2018 </option>
<option value='https://mendovoice.com/2018/10/'> October 2018 </option>
<option value='https://mendovoice.com/2018/09/'> September 2018 </option>
<option value='https://mendovoice.com/2018/08/'> August 2018 </option>
<option value='https://mendovoice.com/2018/07/'> July 2018 </option>
<option value='https://mendovoice.com/2018/06/'> June 2018 </option>
<option value='https://mendovoice.com/2018/05/'> May 2018 </option>
<option value='https://mendovoice.com/2018/04/'> April 2018 </option>
<option value='https://mendovoice.com/2018/03/'> March 2018 </option>
<option value='https://mendovoice.com/2018/02/'> February 2018 </option>
<option value='https://mendovoice.com/2018/01/'> January 2018 </option>
<option value='https://mendovoice.com/2017/12/'> December 2017 </option>
<option value='https://mendovoice.com/2017/11/'> November 2017 </option>
<option value='https://mendovoice.com/2017/10/'> October 2017 </option>
<option value='https://mendovoice.com/2017/09/'> September 2017 </option>
<option value='https://mendovoice.com/2017/08/'> August 2017 </option>
<option value='https://mendovoice.com/2017/07/'> July 2017 </option>
<option value='https://mendovoice.com/2017/06/'> June 2017 </option>
<option value='https://mendovoice.com/2017/05/'> May 2017 </option>
<option value='https://mendovoice.com/2017/04/'> April 2017 </option>
<option value='https://mendovoice.com/2017/03/'> March 2017 </option>
<option value='https://mendovoice.com/2017/02/'> February 2017 </option>
<option value='https://mendovoice.com/2017/01/'> January 2017 </option>
<option value='https://mendovoice.com/2016/12/'> December 2016 </option>
<option value='https://mendovoice.com/2016/11/'> November 2016 </option>
<option value='https://mendovoice.com/2016/10/'> October 2016 </option>
<option value='https://mendovoice.com/2016/09/'> September 2016 </option>
</select>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown--1" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
</div></div>
</div>
<div id="boilerplate">
<div class="row-fluid clearfix">
<div class="span6">
<ul id="footer-social" class="social-icons">
<li><a href="https://www.facebook.com/MendoVoice/" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/themendovoice" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/mendovoice/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://mendovoice.com/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li> </ul>
<div class="footer-bottom clearfix">

<p class="footer-credit">&copy; Copyright 2021, The Mendocino Voice, Mendocino News Media LLC</p>
<ul id="menu-footer-bottom" class="menu"><li id="menu-item-149319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149319"><a href="https://mendovoice.com/about/">About Us</a></li>
<li id="menu-item-149320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149320"><a href="https://mendovoice.com/about/">Contact</a></li>
<li id="menu-item-149321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149321"><a href="https://mendovoice.com/tips/">Tips &#038; Submissions</a></li>
<li id="menu-item-149322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149322"><a href="https://mendovoice.com/advertise/">Advertise</a></li>
<li id="menu-item-156626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156626"><a href="https://mendovoice.com/commenting-and-letter-to-editor-policy/">Policies</a></li>
</ul> </div>
</div>
<div class="span6 right">
<p class="footer-credit footer-credit-padding-inn-logo-missing">Built with the <a href="http://largoproject.org">Largo WordPress Theme</a> from the <a href="http://inn.org">Institute for Nonprofit News</a>.</p>
</div>
</div>
<p class="back-to-top visuallyhidden"><a href="#top">Back to top &uarr;</a></p>
</div>
</footer>
</div>
<script>(function(){var advanced_ads_ga_UID="UA-83666118-1",advanced_ads_ga_anonymIP=!!1;function AdvAdsAdBlockCounterGA(t){this.UID=t,this.analyticsObject="function"==typeof gtag;var n=this;return this.count=function(){gtag("event","AdBlock",{event_category:"Advanced Ads",event_label:"Yes",non_interaction:!0,send_to:n.UID})},function(){if(!n.analyticsObject){var e=document.createElement("script");e.src="https://www.googletagmanager.com/gtag/js?id="+t,e.async=!0,document.body.appendChild(e),window.dataLayer=window.dataLayer||[],window.gtag=function(){dataLayer.push(arguments)},n.analyticsObject=!0,gtag("js",new Date)}var a={send_page_view:!1,transport_type:"beacon"};window.advanced_ads_ga_anonymIP&&(a.anonymize_ip=!0),gtag("config",t,a)}(),this}window.advanced_ads_check_adblocker=function(t){var n=[],e=null;function a(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}return a((function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),a((function(){var a=window.getComputedStyle&&window.getComputedStyle(t),o=a&&a.getPropertyValue("-moz-binding");e=a&&"none"===a.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0,d=n.length;i<d;i++)n[i](e);n=[]}))})),function(t){null!==e?t(e):n.push(t)}}(),advanced_ads_check_adblocker((function(t){t&&new AdvAdsAdBlockCounterGA(advanced_ads_ga_UID).count()}));})();</script><script type="text/template" id="tmpl-floating-social-buttons"><div class="largo-follow post-social clearfix"><span class="more-social-links">
	<a class="popover-toggle" href="#"><i class="icon-plus"></i><span class="hidden-phone">More</span></a>
	<span class="popover">
	<ul>
		<li><a href="https://mendovoice.com/category/mendo/"><i class="icon-link"></i> <span>More on Mendocino</span></a></li>
<li><a href="https://mendovoice.com/category/mendo/feed/"><i class="icon-rss"></i> <span>Subscribe to Mendocino</span></a></li>
	</ul>
	</span>
</span></div></script> <script type="text/javascript" id="floating-social-buttons-width-json">
				window.floating_social_buttons_width = {"min":"1400","max":"9999"}			</script>
<script type="text/javascript" src="https://mendovoice.com/wp-content/themes/largo-0.5.5.4/js/floating-social-buttons.min.js?ver=0.5.5.4" async></script>

<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-qdLCxQQhkacJk",
				source:"wp"
			});
		</script>
<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-qdLCxQQhkacJk.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>

<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/mendovoice.com\/2021\/10\/murder-case-moves-forward-against-alleged-shooter-in-july-homicide-on-bell-springs-road\/":746227};
	</script>
<script type='text/javascript' src='https://mendovoice.com/wp-includes/js/comment-reply.min.js?ver=5.8.1' id='comment-reply-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/plugins/embed-any-document/js/pdfobject.min.js?ver=2.7.0' id='awsm-ead-pdf-object-js'></script>
<script type='text/javascript' id='awsm-ead-public-js-extra'>
/* <![CDATA[ */
var eadPublic = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/plugins/embed-any-document/js/embed-public.min.js?ver=2.7.0' id='awsm-ead-public-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/plugins/advanced-ads-pro/assets/js/advanced-ads-pro.min.js?ver=2.14.1' id='advanced-ads-pro/front-js'></script>
<script type='text/javascript' src='https://mendovoice.com/home/runcloud/webapps/MVwp/wp-content/themes/Largo-Sample-Child-Theme-master/js/your_theme.js?ver=0.1.0' id='your_theme-js'></script>
<script type='text/javascript' id='largoCore-js-extra'>
/* <![CDATA[ */
var Largo = {"is_home":"","is_single":"1","sticky_nav_options":{"sticky_nav_display":true,"main_nav_hide_article":false,"nav_overflow_label":"More"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/js/largoCore.min.js?ver=0.5.5.4' id='largoCore-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/js/navigation.min.js?ver=0.5.5.4' id='largo-navigation-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/js/largoPlugins.js?ver=0.5.5.4' id='largoPlugins-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/lib/navis-slideshows/vendor/slick/slick.min.js?ver=3.0' id='jquery-slick-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/themes/largo-0.5.5.4/lib/navis-slideshows/js/navis-slideshows.js?ver=0.11' id='navis-slideshows-js'></script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/mendovoice.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":"","wp_timezone_offset":"-25200"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/plugins/advanced-ads-pro/assets/js/base.min.js?ver=2.14.1' id='advanced-ads-pro/cache_busting-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"mendo-target","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.1.3' id='advadsTrackingScript-js'></script>
<script type='text/javascript' src='https://mendovoice.com/wp-includes/js/wp-embed.min.js?ver=5.8.1' id='wp-embed-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mendovoice.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.2.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
</script>
<div class="mendo-3c4da6f6234920ca382bd9c1d9efbce1 mendo-fire-sponsorship-place-v2ment" id="mendo-3c4da6f6234920ca382bd9c1d9efbce1"></div><div class="mendo-b5d1188c3f52082a0848bc46c0e8aead mendo-leaderboard" id="mendo-b5d1188c3f52082a0848bc46c0e8aead"></div><div class="mendo-fb9c64f706bc95a3a8f7495858e1fd49 mendo-mobile-leaderboard" id="mendo-fb9c64f706bc95a3a8f7495858e1fd49"></div><script>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</script><script>!function(){window.advanced_ads_ready_queue=window.advanced_ads_ready_queue||[],advanced_ads_ready_queue.push=window.advanced_ads_ready;for(var d=0,a=advanced_ads_ready_queue.length;d<a;d++)advanced_ads_ready(advanced_ads_ready_queue[d])}();</script><script src='https://stats.wp.com/e-202143.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.2.1',blog:'114166732',post:'746227',tz:'-7',srv:'mendovoice.com'} ]);
	_stq.push([ 'clickTrackerInit', '114166732', '746227' ]);
</script>
<script id="mendo-tracking">var advads_tracking_ads = {"1":[724559,722897,723356,723370,722910,724560,724849,724873,724844,722915,724560]};var advads_tracking_urls = {"1":"https:\/\/mendovoice.com\/wp-content\/ajax-handler.php"};var advads_tracking_methods = {"1":"frontend"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/mendovoice.com\/linkout\/"};</script>
<script data-no-optimize="1">var litespeed_vary=document.cookie.replace(/(?:(?:^|.*;\s*)_lscache_vary\s*\=\s*([^;]*).*$)|^.*$/,"$1");litespeed_vary||fetch("https://mendovoice.com/wp-content/plugins/litespeed-cache/guest.vary.php",{method:"POST",cache:"no-cache",redirect:"follow"}).then(e=>e.json()).then(e=>{console.log(e),e.hasOwnProperty("reload")&&"yes"==e.reload&&window.location.reload(!0)});</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6a54960153265c4d","token":"f48b0f6711dd4193baf037a597edca40","version":"2021.10.0","si":100}'></script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6a5496011b1f5c4d',m:'.ox0RC6oAVXyZ8gkZgBg1TK8sVJFF2s1Hwt3rxbvuGg-1635428531-0-AaZUpSyBvUnYtWCxagrF3me9UWKUVgOioOjgcP2lOp0/y8QeqTUvF0oUAtYYcuRQmwrqZMg0Ig82/8dc6Ae401T+E/QjpdxAcbQXnXJ0HBjj7n0qeN+byY3nXXz2MUVtZ83NujHt2EPQPYF+ksUKTeA1bLyPCKFf3cYyQuT5TyJ3811R5qiJsvDH0sir1SmuWU3+CHVnCB0w0xYh+x8K0D/6+EYNoqv9jcF5+JJ8QXpqqE8QFhjrMnPPCWavXRcqvw==',s:[0xcd16bba2b7,0x72b15e333c],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"6a5496011b1f5c4d","token":"f48b0f6711dd4193baf037a597edca40","version":"2021.10.0","si":100}'></script>
</body>
</html>

