<!DOCTYPE html> <!--[if lt IE 7]><html lang="en-US" class="no-js ie6"> <![endif]--> <!--[if IE 7]><html lang="en-US" class="no-js ie7"> <![endif]--> <!--[if IE 8]><html lang="en-US" class="no-js ie8"> <![endif]--> <!--[if IE 9]><html lang="en-US" class="no-js ie9"> <![endif]--> <!--[if (gt IE 9)|!(IE)]><!--><html lang="en-US" class="no-js"> <!--<![endif]--><head> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3057451736576335",
    enable_page_level_ads: true
  });</script> <meta name="google-site-verification" content="JH747qvihYfCLMAhl3_ajUANMbGpb5h7XbuotKZorRQ" /><meta name="google-site-verification" content="S0x4cgaY9fKrtguUegqjdN_FRD0pVnIWDbMDYw6u5eA" /><meta name="google-site-verification" content="eiCgNixAzZIPEyBsKAH6g-U-19QEDZGrZ6J15fzTGuY" /><meta charset="UTF-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0"><link rel="stylesheet" id="ao_optimized_gfonts" href="https://fonts.googleapis.com/css?family=Josefin+Sans%7COswald%7CRoboto&amp;display=swap" /><link media="all" href="https://mendovoice.com/wp-content/cache/autoptimize/css/autoptimize_9ec54091913fb5a426e1487f2952f076.css" rel="stylesheet" /><title> What you need to know about voting &amp; COVID — masks required at polls —Mendocino Co. sees record early voting turn out &bull; The Mendocino VoiceThe Mendocino Voice</title><link rel="profile" href="http://gmpg.org/xfn/11" /><link rel="pingback" href="https://mendovoice.com/xmlrpc.php" /> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script> <script>function whichHeader() {
				var screenWidth = document.documentElement.clientWidth,
				header_img;
				if (screenWidth <= 767) {
					header_img = 'https://mendovoice.com/wp-content/uploads/2018/06/Josefin-Masthead-768.png';
				} else if (screenWidth > 767 && screenWidth <= 979) {
					header_img = 'https://mendovoice.com/wp-content/uploads/2018/06/Josefin-Masthead-980-1.png';
				} else {
					header_img = 'https://mendovoice.com/wp-content/uploads/2018/06/20th-century-Masthead-Autumn-2019-colors-6-2.png';
				}
				return header_img;
			}
			var banner_img_src = whichHeader();</script> <!-- This site is optimized with the Yoast SEO plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ --><title>What you need to know about voting &amp; COVID — masks required at polls —Mendocino Co. sees record early voting turn out &bull; The Mendocino Voice</title><meta name="description" content="Polling stations will be at 25% occupancy, masks will be required, and booths will be cleaned in between votes." /><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="What you need to know about voting &amp; COVID — masks required at polls —Mendocino Co. sees record early voting turn out &bull; The Mendocino Voice" /><meta property="og:description" content="Polling stations will be at 25% occupancy, masks will be required, and booths will be cleaned in between votes." /><meta property="og:url" content="https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/" /><meta property="og:site_name" content="The Mendocino Voice" /><meta property="article:publisher" content="https://www.facebook.com/MendoVoice/" /><meta property="article:published_time" content="2020-11-03T13:10:27+00:00" /><meta property="article:modified_time" content="2020-11-03T13:17:04+00:00" /><meta property="og:image" content="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="683" /><meta property="fb:app_id" content="107934110099788" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@TheMendoVoice" /><meta name="twitter:site" content="@TheMendoVoice" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Adrian Fernandez Baumann"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="6 minutes"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mendovoice.com/#organization","name":"The Mendocino Voice","url":"https://mendovoice.com/","sameAs":["https://www.facebook.com/MendoVoice/","https://www.instagram.com/mendovoice/","https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw","https://twitter.com/TheMendoVoice"],"logo":{"@type":"ImageObject","@id":"https://mendovoice.com/#logo","inLanguage":"en-US","url":"https://mendovoice.com/wp-content/uploads/2018/02/Favicon-Prime.png","width":152,"height":152,"caption":"The Mendocino Voice"},"image":{"@id":"https://mendovoice.com/#logo"}},{"@type":"WebSite","@id":"https://mendovoice.com/#website","url":"https://mendovoice.com/","name":"The Mendocino Voice","description":"Useful news, for all of Mendocino.","publisher":{"@id":"https://mendovoice.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://mendovoice.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#primaryimage","inLanguage":"en-US","url":"https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg","width":750,"height":683,"caption":"Did you vote yet?"},{"@type":"WebPage","@id":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#webpage","url":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/","name":"What you need to know about voting & COVID \u2014 masks required at polls \u2014Mendocino Co. sees record early voting turn out &bull; The Mendocino Voice","isPartOf":{"@id":"https://mendovoice.com/#website"},"primaryImageOfPage":{"@id":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#primaryimage"},"datePublished":"2020-11-03T13:10:27+00:00","dateModified":"2020-11-03T13:17:04+00:00","description":"Polling stations will be at 25% occupancy, masks will be required, and booths will be cleaned in between votes.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/"]}]},{"@type":"Article","@id":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#article","isPartOf":{"@id":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#webpage"},"author":{"@id":"https://mendovoice.com/#/schema/person/6b8874adfc0907236ec8775240ca8b83"},"headline":"What you need to know about voting &#038; COVID \u2014 masks required at polls \u2014Mendocino Co. sees record early voting turn out","datePublished":"2020-11-03T13:10:27+00:00","dateModified":"2020-11-03T13:17:04+00:00","mainEntityOfPage":{"@id":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#webpage"},"commentCount":0,"publisher":{"@id":"https://mendovoice.com/#organization"},"image":{"@id":"https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#primaryimage"},"articleSection":"Mendocino","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#respond"]}]},{"@type":"Person","@id":"https://mendovoice.com/#/schema/person/6b8874adfc0907236ec8775240ca8b83","name":"Adrian Fernandez Baumann","description":"Adrian Fernandez Baumann is the managing editor of The Mendocino Voice and a founder. He lives in the Willits area and has a dog named Bravo."}]}</script> <!-- / Yoast SEO plugin. --><link rel='stylesheet' id='fvm-header-0-css'  href='https://mendovoice.com/wp-content/uploads/cache/fvm/1604354109/out/header-0b7d1a6c1b10b05d439e5b194b6e58faa2bdb0dd.min.css' type='text/css' media='all' /> <script type='text/javascript' src='https://mendovoice.com/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script><script type='text/javascript' id='fvm-header-1-js-extra'>/*  */
var pp_vars = {"publisher_id":"558217d3-9c21-447d-a4d4-f76cd85d4ee2","widget_endpoint":"https:\/\/widget.pico.tools","plugin_version":"0.9.4","widget_version":"96146d52cc49cdab13952c2bfd69159a","pico_context":"widget","post_id":"524609","post_type":"post","post_title":"What you need to know about voting & COVID \u2014 masks required at polls \u2014Mendocino Co. sees record early voting turn out","taxonomies_for_this_post_type":["category","post_tag","post_format","prominence","post-type","series","author"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","ngg_tag","prominence","post-type","series","author"],"show_read_more_button":"1","taxonomies":{"category":["mendocino"],"prominence":["homepage featured","homepage top story"],"author":["adrianfernandezbaumann"]},"resource_ref":"year=2020&monthnum=11&name=what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out"};
/*  */</script> <link rel="https://api.w.org/" href="https://mendovoice.com/wp-json/" /><link rel="alternate" type="application/json" href="https://mendovoice.com/wp-json/wp/v2/posts/524609" /><link rel="alternate" type="application/json+oembed" href="https://mendovoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmendovoice.com%2F2020%2F11%2Fwhat-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out%2F" /><link rel="alternate" type="text/xml+oembed" href="https://mendovoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmendovoice.com%2F2020%2F11%2Fwhat-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out%2F&#038;format=xml" /> <!--<meta name="NextGEN" version="3.3.20" /> --> <script>document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );</script> <meta name="twitter:card" content="summary"><meta name="twitter:site" content="@themendovoice"><meta property="og:title" content="What you need to know about voting &#038; COVID — masks required at polls —Mendocino Co. sees record early voting turn out" /><meta property="og:type" content="article" /><meta property="og:url" content="https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/"/><meta property="og:description" content="Polling stations will be at 25% occupancy, masks will be required, and booths will be cleaned in between votes." /><meta name="description" content="Polling stations will be at 25% occupancy, masks will be required, and booths will be cleaned in between votes." /><meta property="og:site_name" content="The Mendocino Voice" /><meta property="og:image" content="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg" /><link rel="apple-touch-icon" href="https://mendovoice.com/wp-content/uploads/2018/06/Favicon-Autumn-2019-colors-5.jpg"/><link rel="shortcut icon" href="https://mendovoice.com/wp-content/uploads/2018/06/Favicon-Autumn-2019-colors-6.jpg"/><meta name="news_keywords" content="Mendocino"><meta name="original-source" content="https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/" /><meta name="syndication-source" content="https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/" /><meta name="standout" content="https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/"/> <script>var _gaq = _gaq || [];
							_gaq.push(['_setAccount', 'UA-83666118-1']);
				_gaq.push(['_trackPageview']);
										    _gaq.push(
					["largo._setAccount", "UA-17578670-4"],
					["largo._setCustomVar", 1, "SiteName", "The Mendocino Voice"],
					["largo._setDomainName", "mendovoice.com"],
					["largo._setAllowLinker", true],
					["largo._trackPageview"]
				);

			    (function() {
				    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();</script> </head><body class="post-template-default single single-post postid-524609 single-format-standard classic"><div id="top"></div><div class="global-nav-bg"><div class="global-nav"><nav id="top-nav" class="span12"> <span class="visuallyhidden"> <a href="#main" title="Skip to content">Skip to content</a> </span><ul id="menu-global-navigation" class="menu"><li id="menu-item-10348" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10348"><a href="https://mendovoice.com/about/">About Us</a></li><li id="menu-item-149323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149323"><a href="https://mendovoice.com/about/">Contact</a></li><li id="menu-item-10349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10349"><a href="https://mendovoice.com/advertise/">Advertise</a></li><li id="menu-item-10347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10347"><a href="https://mendovoice.com/tips/">Tips</a></li><li id="menu-item-10350" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10350"><a href="mailto:info@mendovoice.com">info@mendovoice.com</a></li></ul><div class="nav-right"><ul id="header-social" class="social-icons visible-desktop"><li><a href="https://www.facebook.com/MendoVoice/" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/themendovoice" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/mendovoice/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://mendovoice.com/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li></ul><div class="donate-btn"><a href="https://mendovoice.com/membership/"><i class="icon-heart"></i>Support us, become a member!</a></div> <!-- BEGIN Header Search --><div id="header-search"><form class="form-search" role="search" method="get" action="https://mendovoice.com/"><div class="input-append"> <input type="text" placeholder="Search" class="input-medium appendedInputButton search-query" value="" name="s" /><button type="submit" class="search-submit btn">GO</button></div></form></div> <!-- END Header Search --></div></nav></div> <!-- /.global-nav --></div> <!-- /.global-nav-bg --><div id="page" class="hfeed clearfix"><div class="sticky-nav-wrapper nocontent"><div class="sticky-nav-holder"><div class="sticky-nav-container"><nav id="sticky-nav" class="sticky-navbar navbar clearfix"><div class="container"><div class="nav-right"><ul id="header-social" class="social-icons visible-desktop"><li><a href="https://www.facebook.com/MendoVoice/" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/themendovoice" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/mendovoice/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://mendovoice.com/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li></ul><ul id="header-extras"><li class="donate"> <a class="donate-link" href="https://mendovoice.com/membership/"> <span><i class="icon-heart"></i>Support us, become a member!</span> </a></li><li id="sticky-nav-search"> <a href="#" class="toggle"> <i class="icon-search" title="Search" role="button"></i> </a><form class="form-search" role="search" method="get" action="https://mendovoice.com/"><div class="input-append"> <span class="text-input-wrapper"> <input type="text" placeholder="Search"
class="input-medium appendedInputButton search-query" value="" name="s" /> </span> <button type="submit" class="search-submit btn">Go</button></div></form></li><li> <!-- "hamburger" button (3 bars) to trigger off-canvas navigation --> <a class="btn btn-navbar toggle-nav-bar" title="More"><div class="bars"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span></div> </a></li></ul></div><!-- BEGIN MOBILE MENU (hidden on desktop) --><div class="nav-left"><ul><li class="home-icon"><a href="https://mendovoice.com/"><noscript><img   alt="logo" data-src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img   alt="logo" data-src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo" alt="logo"></noscript></noscript></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="lazyload attachment-home-logo" alt="logo"></a></li></ul></div> <!-- END MOBILE MENU --><!-- BEGIN DESKTOP MENU --><div class="nav-shelf"><ul class="nav"><li class="home-icon"> <a href="https://mendovoice.com/"> <noscript><img   alt="logo" data-src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img   alt="logo" data-src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="attachment-home-logo" alt="logo"></noscript></noscript></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2018/06/20th-century-stick-graphic-Autumn-2019-colors.jpg" class="lazyload attachment-home-logo" alt="logo"> </a></li><li id="menu-item-156624" class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown menu-item-156624"><a href="https://mendovoice.com/prominence/homepage-featured/" class="dropdown-toggle">News <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-69410" class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-69410"><a href="https://mendovoice.com/prominence/homepage-featured/">Top News</a></li><li id="menu-item-454707" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454707"><a href="https://mendovoice.com/tag/community-info/">Notices &#038; Announcements</a></li><li id="menu-item-62664" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62664"><a href="https://mendovoice.com/latest-news/">Latest News</a></li><li id="menu-item-354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-354"><a href="https://mendovoice.com/category/police-courts/">Police &#038; Courts</a></li><li id="menu-item-10468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10468"><a href="https://mendovoice.com/category/food-farm/">Food &#038; Ag</a></li><li id="menu-item-454691" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454691"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li><li id="menu-item-11391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11391"><a href="https://mendovoice.com/category/education/">Education</a></li><li id="menu-item-11390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11390"><a href="https://mendovoice.com/category/business/">Business &#038; Economy</a></li><li id="menu-item-11392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11392"><a href="https://mendovoice.com/category/health/">Health</a></li><li id="menu-item-10467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10467"><a href="https://mendovoice.com/category/environment-natural-resources/">Environment</a></li><li id="menu-item-406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-406"><a href="https://mendovoice.com/category/weather/">Weather</a></li></ul></li><li id="menu-item-10795" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-10795"><a href="https://mendovoice.com/tag/community-info/" class="dropdown-toggle">Announcements <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-454706" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454706"><a href="https://mendovoice.com/tag/community-info/">Events &#038; Announcements</a></li><li id="menu-item-185668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-185668"><a href="https://mendovoice.com/category/arts-culture/">Arts &#038; Culture <i class="icon-arrow-right"></i></a><ul class="dropdown-menu sub-menu"><li id="menu-item-454708" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454708"><a href="https://mendovoice.com/tag/opinion">Opinions &#038; Voices</a></li></ul></li><li id="menu-item-185669" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185669"><a href="https://mendovoice.com/category/food-farm/">Food &#038; Farming</a></li><li id="menu-item-185670" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185670"><a href="https://mendovoice.com/category/health/">Health</a></li><li id="menu-item-454705" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454705"><a href="https://mendovoice.com/tag/opinion">Columns &#038; Opinion</a></li></ul></li><li id="menu-item-632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-632"><a href="https://mendovoice.com/category/fire-emergency/" class="dropdown-toggle">Fire &#038; Emergency <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-454699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454699"><a href="https://mendovoice.com/tag/calfire/">Cal Fire</a></li><li id="menu-item-454700" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454700"><a href="https://mendovoice.com/tag/earthquake/">Earthquakes</a></li><li id="menu-item-454695" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454695"><a href="https://mendovoice.com/series/2020-fire-season/">Fire Season 2020</a></li><li id="menu-item-454693" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454693"><a href="https://mendovoice.com/series/2019-fire-season/">2019 Fire Season</a></li><li id="menu-item-454690" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454690"><a href="https://mendovoice.com/category/weather/">Weather</a></li></ul></li><li id="menu-item-6330" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6330"><a href="https://mendovoice.com/category/traffic-roads/">Roads</a></li><li id="menu-item-355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-355"><a href="https://mendovoice.com/category/politics-government/" class="dropdown-toggle">Politics <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-454694" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454694"><a href="https://mendovoice.com/series/2020-election/">Election 2020</a></li><li id="menu-item-454692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454692"><a href="https://mendovoice.com/tag/board-of-supervisors/">Board of Supervisors</a></li><li id="menu-item-380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-380"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li><li id="menu-item-10466" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10466"><a href="https://mendovoice.com/tag/opinion">Opinion</a></li></ul></li><li id="menu-item-454689" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-454689"><a href="https://mendovoice.com/category/health/" class="dropdown-toggle">Health <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-454688" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454688"><a href="https://mendovoice.com/series/coronavirus-covid-19/">Coronavirus</a></li></ul></li><li id="menu-item-9790" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-9790"><a href="https://mendovoice.com/membership/" class="dropdown-toggle">Membership <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-453710" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453710"><a href="https://mendovoice.com/membership/">Become a member</a></li><li id="menu-item-453711" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453711"><a href="https://mendovoice.com/membership/faq-membership-and-newsletters/">FAQ: Membership and Newsletters</a></li><li id="menu-item-453719" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453719"><a href="https://mendovoice.com/membership/summer-2020-changes-coming-to-membership-and-newsletters/">Summer 2020: Changes coming to membership and newsletters</a></li><li id="menu-item-454759" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454759"><a href="https://mendovoice.com/membership/subscribe/">Subscribe to our newsletters</a></li></ul></li><li id="menu-item-430" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-430"><a href="https://mendovoice.com/advertise/" class="dropdown-toggle">Ads <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-454678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454678"><a href="https://mendovoice.com/advertise/">Advertise with Mendo Voice</a></li><li id="menu-item-454679" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454679"><a href="https://mendovoice.com/advertise/fire-coverage-community-partners-2019/">Fire Coverage Community Partners, 2019</a></li></ul></li><li id="menu-item-436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-436"><a href="https://mendovoice.com/about/" class="dropdown-toggle">About Us <b class="caret"></b></a></a><ul class="dropdown-menu"><li id="menu-item-453722" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453722"><a href="https://mendovoice.com/membership/">Become a member</a></li><li id="menu-item-149318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149318"><a href="https://mendovoice.com/about/">Contact Us</a></li><li id="menu-item-113862" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113862"><a href="https://mendovoice.com/about/">About Us</a></li><li id="menu-item-444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444"><a href="https://mendovoice.com/about/staff/">Staff</a></li><li id="menu-item-435" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435"><a href="https://mendovoice.com/tips/">Tips</a></li><li id="menu-item-156647" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156647"><a href="https://mendovoice.com/commenting-and-letter-to-editor-policy/">Commenting Policy</a></li><li id="menu-item-454758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454758"><a href="https://mendovoice.com/membership/subscribe/">Subscribe to our newsletters</a></li></ul></li><li id="menu-item-454696" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454696"><a href="https://mendovoice.com/category/weather/">Weather</a></li><li class="donate"> <a class="donate-link" href="https://mendovoice.com/membership/"> <span>Support us, become a member!</span> </a></li><li class="menu-item menu-item-has-childen dropdown"> <a href="javascript:void(0);" class="dropdown-toggle">Global Navigation <b class="caret"></b> </a><ul id="menu-global-navigation-1" class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10348"><a href="https://mendovoice.com/about/">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149323"><a href="https://mendovoice.com/about/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10349"><a href="https://mendovoice.com/advertise/">Advertise</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10347"><a href="https://mendovoice.com/tips/">Tips</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10350"><a href="mailto:info@mendovoice.com">info@mendovoice.com</a></li></ul></li></ul></div></div></nav></div></div></div><div class="header-ad-zone max-wide"><div id="header-ad-zone-container"><aside id="oio-widget-104" class="widget widget-1 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-1"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=97" title="Motosports of Ukiah"><noscript><img  width="728" height="90" border="0" alt="Motosports of Ukiah" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img  width="728" height="90" border="0" alt="Motosports of Ukiah" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" width="728" height="90" border="0" alt="Motosports of Ukiah" /></noscript></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20728%2090%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" width="728" height="90" border="0" alt="Motosports of Ukiah" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-1"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="728px"};})();</script> </aside></div></div><header id="site-header" class="clearfix nocontent" itemscope itemtype="http://schema.org/Organization"><h2 class="visuallyhidden"> <a itemprop="url" href="https://mendovoice.com/"> <span class="sitename" itemprop="name">The Mendocino Voice</span> <span class="tagline" itemprop="description"> - Useful news, for all of Mendocino.</span> </a></h2> <a itemprop="url" href="https://mendovoice.com/"><noscript><img class="header_img" src="" alt="" /></noscript><img class="lazyload header_img" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="" alt="" /></a><meta itemprop="logo" content="https://mendovoice.com/wp-content/uploads/2018/06/Favicon-Autumn-2019-colors-5.jpg"/></header><header class="print-header nocontent"><p> <strong>The Mendocino Voice</strong> (https://mendovoice.com/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/)</p></header><nav id="main-nav" class="navbar clearfix"><div class="navbar-inner"><div class="container"><div class="nav-shelf"><ul class="nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-has-children dropdown menu-item-156624"><a href="https://mendovoice.com/prominence/homepage-featured/" class="dropdown-toggle">News <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-prominence current-post-ancestor current-menu-parent current-post-parent menu-item-69410"><a href="https://mendovoice.com/prominence/homepage-featured/">Top News</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454707"><a href="https://mendovoice.com/tag/community-info/">Notices &#038; Announcements</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62664"><a href="https://mendovoice.com/latest-news/">Latest News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-354"><a href="https://mendovoice.com/category/police-courts/">Police &#038; Courts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10468"><a href="https://mendovoice.com/category/food-farm/">Food &#038; Ag</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454691"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11391"><a href="https://mendovoice.com/category/education/">Education</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11390"><a href="https://mendovoice.com/category/business/">Business &#038; Economy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11392"><a href="https://mendovoice.com/category/health/">Health</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10467"><a href="https://mendovoice.com/category/environment-natural-resources/">Environment</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-406"><a href="https://mendovoice.com/category/weather/">Weather</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-10795"><a href="https://mendovoice.com/tag/community-info/" class="dropdown-toggle">Announcements <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454706"><a href="https://mendovoice.com/tag/community-info/">Events &#038; Announcements</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-185668"><a href="https://mendovoice.com/category/arts-culture/">Arts &#038; Culture <i class="icon-arrow-right"></i></a><ul class="dropdown-menu sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454708"><a href="https://mendovoice.com/tag/opinion">Opinions &#038; Voices</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185669"><a href="https://mendovoice.com/category/food-farm/">Food &#038; Farming</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-185670"><a href="https://mendovoice.com/category/health/">Health</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454705"><a href="https://mendovoice.com/tag/opinion">Columns &#038; Opinion</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-632"><a href="https://mendovoice.com/category/fire-emergency/" class="dropdown-toggle">Fire &#038; Emergency <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454699"><a href="https://mendovoice.com/tag/calfire/">Cal Fire</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454700"><a href="https://mendovoice.com/tag/earthquake/">Earthquakes</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454695"><a href="https://mendovoice.com/series/2020-fire-season/">Fire Season 2020</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454693"><a href="https://mendovoice.com/series/2019-fire-season/">2019 Fire Season</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454690"><a href="https://mendovoice.com/category/weather/">Weather</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6330"><a href="https://mendovoice.com/category/traffic-roads/">Roads</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-355"><a href="https://mendovoice.com/category/politics-government/" class="dropdown-toggle">Politics <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454694"><a href="https://mendovoice.com/series/2020-election/">Election 2020</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-454692"><a href="https://mendovoice.com/tag/board-of-supervisors/">Board of Supervisors</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-380"><a href="https://mendovoice.com/category/cannabis/">Cannabis</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10466"><a href="https://mendovoice.com/tag/opinion">Opinion</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-454689"><a href="https://mendovoice.com/category/health/" class="dropdown-toggle">Health <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-454688"><a href="https://mendovoice.com/series/coronavirus-covid-19/">Coronavirus</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children dropdown menu-item-9790"><a href="https://mendovoice.com/membership/" class="dropdown-toggle">Membership <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453710"><a href="https://mendovoice.com/membership/">Become a member</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453711"><a href="https://mendovoice.com/membership/faq-membership-and-newsletters/">FAQ: Membership and Newsletters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453719"><a href="https://mendovoice.com/membership/summer-2020-changes-coming-to-membership-and-newsletters/">Summer 2020: Changes coming to membership and newsletters</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454759"><a href="https://mendovoice.com/membership/subscribe/">Subscribe to our newsletters</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-430"><a href="https://mendovoice.com/advertise/" class="dropdown-toggle">Ads <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454678"><a href="https://mendovoice.com/advertise/">Advertise with Mendo Voice</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454679"><a href="https://mendovoice.com/advertise/fire-coverage-community-partners-2019/">Fire Coverage Community Partners, 2019</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-436"><a href="https://mendovoice.com/about/" class="dropdown-toggle">About Us <b class="caret"></b></a></a><ul class="dropdown-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453722"><a href="https://mendovoice.com/membership/">Become a member</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149318"><a href="https://mendovoice.com/about/">Contact Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113862"><a href="https://mendovoice.com/about/">About Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444"><a href="https://mendovoice.com/about/staff/">Staff</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435"><a href="https://mendovoice.com/tips/">Tips</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156647"><a href="https://mendovoice.com/commenting-and-letter-to-editor-policy/">Commenting Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454758"><a href="https://mendovoice.com/membership/subscribe/">Subscribe to our newsletters</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-454696"><a href="https://mendovoice.com/category/weather/">Weather</a></li></ul></div></div></div></nav><nav id="secondary-nav" class="clearfix"><div id="topics-bar" class="span12 hidden-phone"><ul id="menu-coronavirus-latest" class="menu"><li class="menu-label">Don&#039;t Miss</li><li id="menu-item-346910" class="menu-item menu-item-type-taxonomy menu-item-object-series menu-item-346910"><a href="https://mendovoice.com/series/coronavirus-covid-19/">Read all about coronavirus in this series</a></li></ul></div></nav><div id="main" class="row-fluid clearfix"><div id="content" class="span8" role="main"><article id="post-524609" class="hnews item post-524609 post type-post status-publish format-standard has-post-thumbnail hentry category-mendo prominence-homepage-featured prominence-top-story featured-media featured-media-image" itemscope itemtype="http://schema.org/Article"><header><h1 class="entry-title mush" itemprop="headline">What you need to know about voting &#038; COVID — masks required at polls —Mendocino Co. sees record early voting turn out</h1><div id="media_image-3" class="widget widget-1 odd default widget widget_media_image"><h2 class="widget-title widget-heading">Thanks to our sponsor</h2><a href="https://www.adventisthealth.org/ukiah-valley/"><noscript><img width="550" height="40"   alt="" style="max-width: 100%; height: auto;" title="Sponsorship" data-srcset="https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840.jpg 550w, https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840-336x24.jpg 336w"  data-src="https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840.jpg" data-sizes="(max-width: 550px) 100vw, 550px" class="image wp-image-178724  attachment-full size-full lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="550" height="40" src="https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840.jpg" class="image wp-image-178724  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="Sponsorship" srcset="https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840.jpg 550w, https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840-336x24.jpg 336w" sizes="(max-width: 550px) 100vw, 550px" /></noscript></noscript><img width="550" height="40" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20550%2040%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840.jpg" class="lazyload image wp-image-178724  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="Sponsorship" data-srcset="https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840.jpg 550w, https://mendovoice.com/wp-content/uploads/2019/06/IMG_20190604_003840-336x24.jpg 336w" data-sizes="(max-width: 550px) 100vw, 550px" /></a></div><h5 class="byline"><span class="by-author"><span class="by">By</span> <span class="author vcard" itemprop="author"> <a class="url fn n" href="https://mendovoice.com/author/adrianfernandezbaumann/" title="Read All Posts By Adrian Fernandez Baumann" rel="author">Adrian Fernandez Baumann</a></span></span><span class="sep"> |</span> <time class="entry-date updated dtstamp pubdate" datetime="2020-11-03T05:10:27-08:00"><span class="time-ago">1 hour ago</span></time></h5><div class="largo-follow post-social clearfix"><span class="more-social-links"> <a class="popover-toggle" href="#"><i class="icon-plus"></i><span class="hidden-phone">More</span></a> <span class="popover"><ul><li><a href="https://mendovoice.com/prominence/homepage-featured/"><i class="icon-link"></i> <span>More on Homepage Featured</span></a></li><li><a href="https://mendovoice.com/prominence/homepage-featured/feed/"><i class="icon-rss"></i> <span>Subscribe to Homepage Featured</span></a></li></ul> </span> </span></div><meta itemprop="description" content="Polling stations will be at 25% occupancy, masks will be required, and booths will be cleaned in between votes.
" /><meta itemprop="datePublished" content="2020-11-03T05:10:27-08:00" /><meta itemprop="dateModified" content="2020-11-03T05:17:04-08:00" /><meta itemprop="image" content="https://mendovoice.com/wp-content/uploads/2016/12/voted1-150x150.jpg" /></header><!-- / entry header --><div class="breadcrumbs" typeof="BreadcrumbList" vocab="http://schema.org/"><div class="hero is-image "> <noscript><img width="750" height="683"   alt="" data-srcset="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg 750w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-300x273.jpg 300w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-461x420.jpg 461w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-640x583.jpg 640w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-681x620.jpg 681w"  data-src="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg" data-sizes="(max-width: 750px) 100vw, 750px" class="attachment-full size-full wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="750" height="683" src="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg" class="attachment-full size-full wp-post-image" alt="" srcset="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg 750w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-300x273.jpg 300w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-461x420.jpg 461w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-640x583.jpg 640w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-681x620.jpg 681w" sizes="(max-width: 750px) 100vw, 750px" /></noscript></noscript><img width="750" height="683" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20750%20683%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg" class="lazyload attachment-full size-full wp-post-image" alt="" data-srcset="https://mendovoice.com/wp-content/uploads/2016/12/voted1.jpg 750w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-300x273.jpg 300w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-461x420.jpg 461w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-640x583.jpg 640w, https://mendovoice.com/wp-content/uploads/2016/12/voted1-681x620.jpg 681w" data-sizes="(max-width: 750px) 100vw, 750px" /><p class="wp-caption-text">Did you vote yet?</p></div><div class="entry-content clearfix" itemprop="articleBody"><div id="pico"><p>WILLITS, 10/2/20 &#8212; Since the outbreak of COVID, officials and the public alike, have worried about what it might mean for voting. To that end public officials have made extensive preparations to hold elections safely in Mendocino County, to try to keep this election from resulting in a COVID surge, and to keep us in the &#8220;red tier.&#8221;</p><p>We talked with Mendocino County Assessor-Clerk-Recorder Katrina Bartolomie and Public Health Officer Dr. Andy Coren about just what safety precautions will be in place at the polls, and what to expect.</p><p>The first, and perhaps best precaution, has been a major push for Californians to vote by mail, and Mendonesians have heeded the call — as of this evening the county elections division of the Assessor-Clerk-Recorder&#8217;s office has received about 32,000 ballots, either by mail or in drop boxes, out of a total 53,697 registered voters (<a href="#voter-registration">see here for full voter registration data</a>). That&#8217;s about 59% of all registered voters, which by itself would be quite a high turn out.</p><aside class="scaip scaip-1    "><aside id="oio-widget-100" class="widget widget-1 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-4"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=124" title="Ukiah Natural Foods Co-op ad"><noscript><img  width="300" height="250" border="0" alt="Ukiah Natural Foods Co-op ad" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/ncfLgg_Thanksgiving Ad 2020.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/ncfLgg_Thanksgiving Ad 2020.jpg" width="300" height="250" border="0" alt="Ukiah Natural Foods Co-op ad" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/ncfLgg_Thanksgiving Ad 2020.jpg" width="300" height="250" border="0" alt="Ukiah Natural Foods Co-op ad" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-4"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside></aside><p>On the subject of on-site COVID protection Bartolomie explained that all poll workers are required to wear a mask at all times while inside the polling station. People filing into the polling station are also required to wear a mask while inside and voting. Polling stations will have free masks on-site to hand out to anyone who forgets their mask. Polls sites will also be adhering to the same restrictions as restaurants and churches, and only allow people up to 25% capacity of the building. Finally, in between voters poll workers are expected to enter the booth and wipe down that booth with sanitizers.</p><p>Dr. Coren noted that mask use and social distancing remain all important especially in such a public event, and that voters should use hand sanitizers both before and after going into the voting booth. He added that anyone who has is in isolation or quarantine should stay away from the polls. But, &#8220;other than that, I think that the precautions from my understanding are pretty well being follow to minimize contagion and make it safe for them.&#8221;</p><p>If a voter cannot wear a mask for some reason, Bartolomie explained, they will be assisted by a poll worker in filling out their ballot outside. &#8220;If they refuse or they can&#8217;t [wear a mask] then we help them outside — like curbside voting,&#8221; said Bartolomie.</p><aside class="scaip scaip-2    "><aside id="oio-widget-101" class="widget widget-1 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-4"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=135" title=""><noscript><img  width="300" height="250" border="0" alt="" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/29oPcj_West Company Grants.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/29oPcj_West Company Grants.jpg" width="300" height="250" border="0" alt="" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/29oPcj_West Company Grants.jpg" width="300" height="250" border="0" alt="" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-4"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside></aside><p>However, some polling locations are large enough that they may set aside a special separate room for people who, for whatever reason, cannot wear a mask. Still, even in this case those people are not to be allowed to enter the main polling room.</p><p>The elections office has also moved overly small polling locations to the Ukiah fairgrounds. &#8220;We&#8217;ve tried to eliminate our tiny little places,&#8221; said Bartolomie. This means that the two polls usually located at Fowler Automotive, along with the poll at the Assemblies of God Church on Barns St., the poll in the County&#8217;s main office, and the one at St. Mary&#8217;s Catholic Church have all been moved to the fairgrounds.</p><p>Poll workers are also being asked to stay home if they have any illness or symptoms. &#8220;We told all of our poll workers, we&#8217;ve had about ten of them cancel this morning, that if they&#8217;re not feeling well to not come in,&#8221; noted Bartolomie.</p><aside class="scaip scaip-3    "><aside id="oio-widget-102" class="widget widget-1 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-2"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=72" title="Ukiah Farmer&#039;s Market ad"><noscript><img  width="300" height="250" border="0" alt="Ukiah Farmer&#039;s Market ad" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/bFOder_Ukiah farmers market ad-4.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/bFOder_Ukiah farmers market ad-4.jpg" width="300" height="250" border="0" alt="Ukiah Farmer&#039;s Market ad" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/bFOder_Ukiah farmers market ad-4.jpg" width="300" height="250" border="0" alt="Ukiah Farmer&#039;s Market ad" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-2"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside></aside><p>Each polling station has also been provided with PPE and cleaning supplies. Each station has five sneeze guards, sanitizing wipes, hospital grade sanitizer, etc.</p><p>Coren remains optimistic that voting will not lead to a significant bump in the case rate, let alone a surge, in Mendocino County. Said the public health officer, &#8220;Hopefully it will not cause a significant increase. But, if people are congested around polling places that&#8217;s going to increase the risk.&#8221;</p><h5>Early voting details</h5><p>Ballots have been coming into the Election Division for weeks now, and as of Monday evening the about 32,000 ballots had been received. Bartolomie noted that this was in contrast to previous years, which averaged about 9,000 early ballots.</p><aside class="scaip scaip-4    "><aside id="oio-widget-103" class="widget widget-1 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-4"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=136" title=""><noscript><img  width="300" height="250" border="0" alt="" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/x9mgyD_JonKennedy-DigitalAd.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/x9mgyD_JonKennedy-DigitalAd.jpg" width="300" height="250" border="0" alt="" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/x9mgyD_JonKennedy-DigitalAd.jpg" width="300" height="250" border="0" alt="" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-4"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside></aside><p>Bartolomie also said that the new vote counting system that they&#8217;ve implemented has sped up their counting greatly, and given the head-start her office has with all the early ballots, she hopes to have the final tallies done more quickly than in years past.</p><p>The first vote tally, constituting early voting and mail-in ballots, will be released shortly after 8 p.m. when the polls close. At that point individual polling stations will begin to pack up the ballots that have been cast in person and send them off to the election office at the County of Mendocino offices on Low Gap Road in Ukiah. This means that though a huge number of votes have already been recieved, and polls close tomorrow at 8 p.m., the straggler mail-in ballots often delay the final official tally for a couple weeks.</p><p>Ballots can also continue to be dropped in drop-off slots until 8 p.m. Mail-in ballot mailed on Tuesday, so long as they are post-marked Election Day. These ballots mailed at the last minute often constitute a substantial bundle, as do mail-in ballots that voters hand deliver to polling locations.</p><aside class="scaip scaip-5    "><aside id="oio-widget-106" class="widget widget-1 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-5"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=63" title="Mendocino Voice ad sale"><noscript><img  width="300" height="250" border="0" alt="Mendocino Voice ad sale" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img  width="300" height="250" border="0" alt="Mendocino Voice ad sale" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" width="300" height="250" border="0" alt="Mendocino Voice ad sale" /></noscript></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" width="300" height="250" border="0" alt="Mendocino Voice ad sale" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-5"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside></aside><p>As those ballots arrive the election workers will begin counting those same day ballots. They&#8217;ll stay at the office counting as late as they have to, to make sure that all ballots cast on election day are counted before the next morning. This is usually pretty quick for precincts in Ukiah, but ballots coming from Gualala can take quite a while to get to Ukiah, and the count is usually not done till the wee hours of the morning.</p><p>The results will be posted to the Mendocino County election&#8217;s page, and also here on The Mendocino Voice.</p><p>Asked about what she thinks about the election more generally, Bartolomie contrasted the general state of anxiety felt nationwide with the tranquil and routine nature of voting in Mendocino. Indeed this is an unusually sleepy election in Mendo, with few ballot measures and no competitive elections for the Point Arena, Fort Bragg, and Willits city councils. In the First District, where Jon Kennedy is facing Glenn McGourty, the primary saw a lopsided result with McGourty narrowly missing the outright majority necessary to win in the first round. In District 2, with Maureen Mulheren and Mari Rodin running, Rodin announced some weeks ago that she had been diagnosed with cancer, and has curtailed her public appearances since.</p><p>Said Bartolomie, &#8220;Our biggest thing is people watch TV and all the crap that&#8217;s going on in other states, and in Southern California&#8230;we&#8217;re lucky up here, we don&#8217;t have that stuff going on&#8230;I just don&#8217;t see that happening.&#8221;</p><h5>COVID safety in the elections office</h5><p>A reader, Anika Meri, called in to The Mendocino Voice early today and explained that she had spend about half an hour in the Assessor-Clerk-Recorder&#8217;s office, which is also the elections office, and was frustrated to see that many of the staff were not continuously wearing masks.</p><p>Meri explained that she had had an issue with the voting rolls, and found that she had been dropped from voting rolls. She cast a provisional ballot, and was required to stay in the large room while filling out her ballot. During that time she explained that she was apprehensive to see many workers not wearing masks.</p><p>The Assessor&#8217;s Office had one worker die of COVID in late August, though again, that office and the election division are housed in the same large room. Contact tracing determined that the deceased had not contracted COVID at work, and the office was thoroughly cleaned.</p><p>Asked about this Bartolomie explained that workers are not required to wear masks while at their desks, as their desks have been moved six feet apart. Indeed, they do not habitually wear masks so long as they maintain social distancing of six feet. They do, however, don the masks to approach the public at the front counter, said Bartolomie.</p><p>&#8220;If we&#8217;re at our desks we don&#8217;t have to wear them, because our desks are six feet apart.&#8221;</p><p>As she spoke on the phone for this interview Bartolomie explained that she was in counting room with another worker, but that because they were about eight feet, neither was wearing a mask.</p><p>Bartolomie added that the office has several mobile air purifying units scattered about, in additional to central air.</p><h5>Public health officer comments</h5><p>We also reached out to Mendocino County Public Health Officer Dr. Andy Coren, who praised the use of early voting that Mendocino citizens have so enthusiastically adopted.</p><p>&#8220;It&#8217;s good that so many people have done the absentee or early mail-in voting, that will really reduce the congestion around voting places.&#8221;</p><hr class="wp-block-separator"/><div class="wp-block-group"><div class="wp-block-group__inner-container"><h5 id="voter-registration">*Notes on voter registration rate in Mendocino County</h5><p>As of October 19, 2020 there were <strong>53,697</strong> people registered to vote in Mendocino County. In this short section we breakdown what exactly that means.</p><p><a href="https://www.census.gov/quickfacts/mendocinocountycalifornia">According to the United State&#8217;s Census</a> the <strong>population of Mendocino County is estimated at 86,749 </strong>as of June 1, 2019. Of that, an estimated 78.9% are over 18 years of age, giving a <strong>total adult population of 68,445</strong>.</p><p>A felony conviction does not prohibit a person from voting in California, however, people on parole are not allowed to vote until they have completed said parole, at which time their voting rights are restored.</p><p>The census does not currently ask questions of citizenship or keep a count of citizens — citizenship being a requirement for voting in most U.S. elections (though it historically was not in many states). According to the Census, <strong>13% of the residents of Mendocino County are foreign born</strong>, or 12,277 people. Of those an unknown number are children (ineligible to vote anyway) and an unknown number are naturalized adults (now eligible to vote).</p><p>In its Report of Registration for October 19, 2020 the California Secretary of State&#8217;s office estimated the<strong> total number of eligible voters </strong>in Mendocino County (citizens over 18-years-of-age, not currently in state or federal prison or on parole for felony crimes) at <strong>63,021 people, or 92% of adults</strong>. As of Oct. 19, 2020 there were <strong>53,697 people registered</strong> to vote in the County of Mendocino, or<strong> 85.2% of eligible voters, and 78.45% of adults.</strong></p><p>The following are registration numbers are from the California Secretary of State&#8217;s Reporter of Registration for October 19, 2020 for Mendocino County:</p><p>Eligible voters: 63,021<br>Registered Voters: 53,697<br>Registered Democrats: 26,286<br>Registered Republicans: 11,242<br>Registered American Independent Party: 1,945<br>Registered Green Party: 803<br>Registered voters not registered as Democrat, Republican, Independent, or Green: 13,421</p></div></div></div></div><!-- .entry-content --><footer class="post-meta bottom-meta"></footer><!-- /.post-meta --></article><!-- #post-524609 --><div class="article-bottom nocontent"><aside id="largo-tag-list-widget-2" class="widget widget-1 odd default largo-tag-list clearfix"> <!-- Post tags --><div class="tags clearfix"><h5>Filed Under:</h5><ul><li class="post-category-link"><a href="https://mendovoice.com/category/mendo/" title="Read Articles in the Mendocino category">Mendocino</a></li></ul></div></aside><aside id="custom_html-4" class="widget_text widget widget-2 even default widget_custom_html clearfix"><div class="textwidget custom-html-widget"><form class="PicoSignupForm"><h4 style="color:red;">Get the news in your inbox</h4><h5 style="color:black;"> Sign up for our headlines newsletter!</h5> <input type="email" placeholder="Email"><br> <input type="submit" value="sign up"></form></div></aside><aside id="largo-donate-widget-3" class="widget widget-3 odd default largo-donate clearfix"><h3 class="widgettitle">Do you find this news service valuable?</h3><p>Help maintain it by becoming a member.</p> <a class="btn btn-primary" href="https://mendovoice.com/membership/#single-contribution">Become a member!</a></aside><aside id="largo-donate-widget-7" class="widget widget-4 even default largo-donate clearfix"><h3 class="widgettitle">Ok, did you enjoy this article but no others?</h3><p>That&#039;s fine, consider a one time contribution to keep local journalism going.</p> <a class="btn btn-primary" href="https://mendovoice.com/membership/">Contribute</a></aside><aside id="oio-widget-105" class="widget widget-5 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-1"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=134" title="Mo 4 Mendo"><noscript><img  width="728" height="90" border="0" alt="Mo 4 Mendo" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/iDA2hB_Maureen Mulheren General election leaderboard.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/iDA2hB_Maureen Mulheren General election leaderboard.jpg" width="728" height="90" border="0" alt="Mo 4 Mendo" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20728%2090%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/iDA2hB_Maureen Mulheren General election leaderboard.jpg" width="728" height="90" border="0" alt="Mo 4 Mendo" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-1"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="728px"};})();</script> </aside></div><div id="comments" class="clearfix"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/11/what-you-need-to-know-about-voting-covid-masks-required-at-polls-mendocino-co-sees-record-early-voting-turn-out/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://mendovoice.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='524609' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f0a6855f14" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="242"/></p></form></div><!-- #respond --></div><!-- #comments --></div><aside id="sidebar" class="span4 nocontent"><div class="widget-area" role="complementary"><aside id="oio-widget-94" class="widget widget-1 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-2"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=137" title=""><noscript><img  width="300" height="250" border="0" alt="" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/ypPp0p_JonKennedy-DigitalAd2.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/ypPp0p_JonKennedy-DigitalAd2.jpg" width="300" height="250" border="0" alt="" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/ypPp0p_JonKennedy-DigitalAd2.jpg" width="300" height="250" border="0" alt="" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-2"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside><aside id="largo-tag-list-widget-3" class="widget widget-2 even default largo-tag-list clearfix"> <!-- Post tags --><div class="tags clearfix"><h5>Filed Under:</h5><ul><li class="post-category-link"><a href="https://mendovoice.com/category/mendo/" title="Read Articles in the Mendocino category">Mendocino</a></li></ul></div></aside><aside id="largo-series-posts-widget-5" class="widget widget-3 odd default largo-series-posts clearfix"><h3 class="widgettitle"><a href="https://mendovoice.com/series/coronavirus-covid-19/">Coronavirus</a></h3> <a href="https://mendovoice.com/2020/10/new-small-business-grants-available-to-help-with-covid-19-changes-west-center-has-up-to-10000-for-local-businesses/"><noscript><img width="140" height="140"   alt="" data-srcset="https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-140x140.jpg 140w, https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-500x500.jpg 500w"  data-src="https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-140x140.jpg" data-sizes="(max-width: 140px) 100vw, 140px" class="left-align attachment-thumbnail wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="140" height="140" src="https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-140x140.jpg" class="left-align attachment-thumbnail wp-post-image" alt="" srcset="https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-140x140.jpg 140w, https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-500x500.jpg 500w" sizes="(max-width: 140px) 100vw, 140px" /></noscript></noscript><img width="140" height="140" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20140%20140%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-140x140.jpg" class="lazyload left-align attachment-thumbnail wp-post-image" alt="" data-srcset="https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-140x140.jpg 140w, https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-60x60.jpg 60w, https://mendovoice.com/wp-content/uploads/2020/04/cornerssign2-500x500.jpg 500w" data-sizes="(max-width: 140px) 100vw, 140px" /></a><h5> <a href="https://mendovoice.com/2020/10/new-small-business-grants-available-to-help-with-covid-19-changes-west-center-has-up-to-10000-for-local-businesses/">New small business grants available to help with COVID-19 changes — West Center has up to $10,000 for local businesses </a></h5><p>Two different grant opportunities are open for local businesses implementing changes due to COVID-19.</p><h5 class="series-split top-tag">Explore:</h5><ul><li><a href="https://mendovoice.com/2020/08/mendocino-county-covid-19-tally/">Seventeen dead of COVID including a county worker, new public health order issued — 673 total cases, 5 currently hospitalized, Aug. 28</a></li><li><a href="https://mendovoice.com/2020/08/three-die-of-covid-at-hospital-this-week-one-covid-related-death-at-sherwood-oaks/">One more dead of COVID today, five total this week — four die of COVID at hospital, one COVID-related death at Sherwood Oaks (update 2:10pm)</a></li><li><a href="https://mendovoice.com/2020/08/west-center-opens-second-round-of-grants-to-assist-businesses-with-covid-19-changes-on-friday-august-21-100000-total-available/">West Center opens second round of grants to assist businesses with COVID-19 changes on Friday August 21 — $100,000 total available</a></li><li><a href="https://mendovoice.com/2020/08/adventist-health-implements-virtual-hospital-program-to-expand-capacity-and-offer-home-treatment-during-the-pandemic/">Adventist Health implements virtual hospital program to expand capacity and offer home treatment during the pandemic</a></li></ul><a class="more" href="https://mendovoice.com/series/coronavirus-covid-19/">Complete Coverage</a></aside><aside id="oio-widget-95" class="widget widget-4 even default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-3"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=65" title="Support local business, advertise with the Mendo Voice"><noscript><img  width="300" height="600" border="0" alt="Support local business, advertise with the Mendo Voice" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/VxpvIJ_Subscribe ad 6 (10).jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/VxpvIJ_Subscribe ad 6 (10).jpg" width="300" height="600" border="0" alt="Support local business, advertise with the Mendo Voice" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20600%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/VxpvIJ_Subscribe ad 6 (10).jpg" width="300" height="600" border="0" alt="Support local business, advertise with the Mendo Voice" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-3"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside><aside id="oio-widget-96" class="widget widget-6 even default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-5"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=63" title="Mendocino Voice ad sale"><noscript><img  width="300" height="250" border="0" alt="Mendocino Voice ad sale" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img  width="300" height="250" border="0" alt="Mendocino Voice ad sale" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" width="300" height="250" border="0" alt="Mendocino Voice ad sale" /></noscript></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/Cr56OL_MendoVoiceAd_NewYear.jpg" width="300" height="250" border="0" alt="Mendocino Voice ad sale" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-5"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside><aside id="largo-recent-posts-widget-22" class="widget widget-7 odd default largo-recent-posts clearfix"><h3 class="widgettitle">Recent Articles</h3><ul><li><h5> <a href="https://mendovoice.com/2020/11/how-and-where-to-vote-on-election-day-in-mendocino-county/">How, and where, to vote on Election Day in Mendocino County </a></h5></li><li><h5> <a href="https://mendovoice.com/2020/11/mendocino-county-election-2020-live-blog-32000-ballots-already-received-same-day-voting-begins-in-mendocino-county-covid-precautions-abound/">Mendocino County election 2020 live blog — 32,000 ballots already received — same day voting begins in Mendocino County — COVID precautions abound </a></h5></li><li><h5> <a href="https://mendovoice.com/2020/11/endorsements-letters-in-support-of-candidates-opinion/">Endorsements &#038; letters in support of candidates (opinion) </a></h5></li><li><h5> <a href="https://mendovoice.com/2020/11/hey-undecided-voters-here-are-our-interviews-with-the-candidates-our-election-forums/">Hey undecided voters! Here are our interviews with the candidates &#038; our election forums </a></h5></li><li><h5> <a href="https://mendovoice.com/2020/11/sheriff-will-run-extra-patrols-election-day-citing-concerns-of-intimidation-or-violence-in-connection-with-voting/">Sheriff will run extra patrols Election Day, citing concerns of &#8220;intimidation or violence in connection with voting&#8221; </a></h5></li><li><h5> <a href="https://mendovoice.com/2020/11/ft-bragg-ukiah-schools-likely-to-reopen-soon-under-hybrid-model-under-red-tier-schools-may-open-as-soon-as-nov-12/">Ft. Bragg &#038; Ukiah schools likely to reopen soon under hybrid model — under red tier schools may open as soon as Nov. 12 </a></h5></li><li><h5> <a href="https://mendovoice.com/2020/11/mo-mulheren-supports-farmers-market-ebt-match-program-letter-to-the-editor/">Mo Mulheren supports Farmers&#8217; Market EBT Match program (letter to the editor) </a></h5></li><li><h5> <a href="https://mendovoice.com/2020/11/ukiah-hires-goats-to-prevent-wildfire/">Local goats clear brush in Ukiah, or four-footed friends make fast work of future flame fuel </a></h5></li></ul></aside><aside id="oio-widget-97" class="widget widget-8 even default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-6"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=120" title=""><noscript><img  width="300" height="250" border="0" alt="" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/FbbD3L_JoshBowersSEO.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/FbbD3L_JoshBowersSEO.jpg" width="300" height="250" border="0" alt="" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/FbbD3L_JoshBowersSEO.jpg" width="300" height="250" border="0" alt="" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-6"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside><aside id="custom_html-5" class="widget_text widget widget-9 odd default widget_custom_html clearfix"><div class="textwidget custom-html-widget"><form class="PicoSignupForm"><h4 style="color:red;">Get the news in your inbox</h4><h5 style="color:black;"> Sign up for our headlines newsletter!</h5> <input type="email" placeholder="Email"><br> <input type="submit" value="sign up"></form></div></aside><aside id="largo-series-posts-widget-2" class="widget widget-10 even default largo-series-posts clearfix"><h3 class="widgettitle"><a href="https://mendovoice.com/series/2020-fire-season/">Fire Season 2020</a></h3> <a href="https://mendovoice.com/2020/10/structure-fire-burning-north-of-potter-valley-some-spread-into-wildland/"><noscript><img width="140" height="140"   alt="" data-srcset="https://mendovoice.com/wp-content/uploads/2020/10/img_0465-140x140.jpg 140w, https://mendovoice.com/wp-content/uploads/2020/10/img_0465-60x60.jpg 60w"  data-src="https://mendovoice.com/wp-content/uploads/2020/10/img_0465-140x140.jpg" data-sizes="(max-width: 140px) 100vw, 140px" class="left-align attachment-thumbnail wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="140" height="140" src="https://mendovoice.com/wp-content/uploads/2020/10/img_0465-140x140.jpg" class="left-align attachment-thumbnail wp-post-image" alt="" srcset="https://mendovoice.com/wp-content/uploads/2020/10/img_0465-140x140.jpg 140w, https://mendovoice.com/wp-content/uploads/2020/10/img_0465-60x60.jpg 60w" sizes="(max-width: 140px) 100vw, 140px" /></noscript></noscript><img width="140" height="140" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20140%20140%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2020/10/img_0465-140x140.jpg" class="lazyload left-align attachment-thumbnail wp-post-image" alt="" data-srcset="https://mendovoice.com/wp-content/uploads/2020/10/img_0465-140x140.jpg 140w, https://mendovoice.com/wp-content/uploads/2020/10/img_0465-60x60.jpg 60w" data-sizes="(max-width: 140px) 100vw, 140px" /></a><h5> <a href="https://mendovoice.com/2020/10/structure-fire-burning-north-of-potter-valley-some-spread-into-wildland/">Structure fire north of Potter Valley quickly knocked down </a></h5><p>UODATE 5:05 p.m. — The fire has been controlled, through fore fighters remain on the scene to Moo up. Resource have already been recalled and structure is hardly smoking thanks to the quick work of local firefighters. ORIGINAL POTTER VALLEY, 10/26/20 — A barn is burning north of Potter Valley and the fire has spread [&hellip;]</p><h5 class="series-split top-tag">Explore:</h5><ul><li><a href="https://mendovoice.com/2020/10/fire-crews-mopping-up-fire-on-orr-springs-road-ukiah-area/">Fire crews mopping up fire on Orr Springs Road in the Ukiah area</a></li><li><a href="https://mendovoice.com/2020/10/nws-issues-red-flag-warning-for-interior-north-coast-above-1500-ft-from-wednesday-night-through-friday-morning-planned-power-shutoffs-unlikely-in-mendocino-county-but-may-occur-in-northern/">NWS issues red flag warning for interior North Coast above 1500 ft., from Wednesday night through Friday morning — planned power shutoffs unlikely in Mendocino County but may occur in Northern CA</a></li><li><a href="https://mendovoice.com/2020/10/august-complex-virtual-community-meeting-happening-tonight-october-12-at-7pm/">August Complex virtual community meeting happening tonight, October 12 at 7pm</a></li><li><a href="https://mendovoice.com/2020/10/red-flag-warning-called-for-interior-mendocino-co-western-lake-co-flex-alert-issued/">Red flag warning called for  interior Mendocino Co., western Lake Co. — flex alert issued</a></li></ul><a class="more" href="https://mendovoice.com/series/2020-fire-season/">Complete Coverage</a></aside><aside id="oio-widget-98" class="widget widget-11 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-4"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=133" title=""><noscript><img  width="300" height="250" border="0" alt="" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/4E76Ju_rodin_online_ad_imdc.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/4E76Ju_rodin_online_ad_imdc.jpg" width="300" height="250" border="0" alt="" /></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20300%20250%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/4E76Ju_rodin_online_ad_imdc.jpg" width="300" height="250" border="0" alt="" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-4"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="300px"};})();</script> </aside><aside id="largo-prev-next-post-links-widget-2" class="widget widget-12 even default largo-prev-next-post-links clearfix"><nav id="nav-below" class="pager post-nav clearfix"><div class="previous"><a href="https://mendovoice.com/2020/11/endorsements-letters-in-support-of-candidates-opinion/"><noscript><img  data-src="https://mendovoice.com/wp-content/uploads/2018/10/Opinion-graphic-6-140x140.jpg" class="thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="thumb" src="https://mendovoice.com/wp-content/uploads/2018/10/Opinion-graphic-6-140x140.jpg" /></noscript></noscript><img class="lazyload thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2018/10/Opinion-graphic-6-140x140.jpg" /><h5>Previous Article</h5><span class="meta-nav">Endorsements & letters in support of candidates (opinion)</span></a></div><div class="next"><a href="https://mendovoice.com/2020/11/mendocino-county-election-2020-live-blog-32000-ballots-already-received-same-day-voting-begins-in-mendocino-county-covid-precautions-abound/"><noscript><img  data-src="https://mendovoice.com/wp-content/uploads/2016/10/IMG_4956-150x150.jpg" class="thumb lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img class="thumb" src="https://mendovoice.com/wp-content/uploads/2016/10/IMG_4956-150x150.jpg" /></noscript></noscript><img class="lazyload thumb" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/uploads/2016/10/IMG_4956-150x150.jpg" /><h5>Next Article</h5><span class="meta-nav">Mendocino County election 2020 live blog — 32,000 ballots already received — same day voting begins in Mendocino County — COVID precautions abound</span></a></div></nav><!-- #nav-below --></aside><aside id="oio-widget-99" class="widget widget-13 odd default oio clearfix"><ul class="oio-banner-zone" id="oio-banner-1"><li class="oio-slot oio-last-col oio-last-row"><a rel="nofollow" href="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/go.php?id=97" title="Motosports of Ukiah"><noscript><img  width="728" height="90" border="0" alt="Motosports of Ukiah" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img  width="728" height="90" border="0" alt="Motosports of Ukiah" data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" width="728" height="90" border="0" alt="Motosports of Ukiah" /></noscript></noscript></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20728%2090%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/uploads/jxgiYj_HondaMotosportsUkiah_Letterboard_Ad_003.jpg" width="728" height="90" border="0" alt="Motosports of Ukiah" /></a></li></ul> <script>(function(){for(var a=document.getElementById("oio-banner-1"),b=a,c,d=window.getComputedStyle;!a.clientWidth;){b=b.parentNode;if(!b||!d||1!==b.nodeType)break;c=d(b,null).getPropertyValue("float");if("left"==c||"right"==c)b.style.width="100%",b.style.maxWidth="728px"};})();</script> </aside></div></aside></div> <!-- #main --></div><!-- #page --><div class="footer-bg clearfix nocontent"><footer id="site-footer"><div id="supplementary" class="row-fluid _3col-default"><div class="span3 widget-area" role="complementary"><aside id="largo-about-widget-2" class="widget widget-1 odd default largo-about clearfix"><h3 class="widgettitle">About The Mendocino Voice</h3><p>The Mendocino Voice is a local, worker-owned, news service -- based in, and covering Mendocino County. We believe in useful news for all of Mendocino.</p></aside></div><div class="span6 widget-area" role="complementary"><aside id="categories-6" class="widget widget-1 odd default widget_categories clearfix"><h3 class="widgettitle">Categories</h3><form action="https://mendovoice.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' ><option value='-1'>Select Category</option><option class="level-0" value="78">Arts &amp; Culture</option><option class="level-0" value="47">Business &amp; Labor</option><option class="level-0" value="43">Cannabis</option><option class="level-0" value="60">Education</option><option class="level-0" value="50">Environment &amp; Natural Resources</option><option class="level-0" value="40">Fire &amp; Emergency</option><option class="level-0" value="48">Food &amp; Farming</option><option class="level-0" value="1770">Health</option><option class="level-0" value="4">Mendocino</option><option class="level-0" value="41">Police &amp; Courts</option><option class="level-0" value="38">Politics &amp; Government</option><option class="level-0" value="305">Roads &amp; Transportation</option><option class="level-0" value="85">Weather</option> </select></form> <script type="text/javascript">/*  */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/*  */</script> </aside></div><div class="span3 widget-area" role="complementary"><div class="widget widget_search"><h2 class="widgettitle">Search This Site</h2><form class="form-search" role="search" method="get" action="https://mendovoice.com/"><div class="input-append"> <input type="text" placeholder="Search" class="searchbox search-query" value="" name="s" /><button type="submit" name="search submit" class="search-submit btn">Go</button></div></form></div><div class="widget widget_archive"><h2 class="widgettitle">Browse Archives</h2> <label class="screen-reader-text" for="archives-dropdown--1">Browse Archives</label> <select id="archives-dropdown--1" name="archive-dropdown"><option value="">Select Month</option><option value='https://mendovoice.com/2020/11/'> November 2020</option><option value='https://mendovoice.com/2020/10/'> October 2020</option><option value='https://mendovoice.com/2020/09/'> September 2020</option><option value='https://mendovoice.com/2020/08/'> August 2020</option><option value='https://mendovoice.com/2020/07/'> July 2020</option><option value='https://mendovoice.com/2020/06/'> June 2020</option><option value='https://mendovoice.com/2020/05/'> May 2020</option><option value='https://mendovoice.com/2020/04/'> April 2020</option><option value='https://mendovoice.com/2020/03/'> March 2020</option><option value='https://mendovoice.com/2020/02/'> February 2020</option><option value='https://mendovoice.com/2020/01/'> January 2020</option><option value='https://mendovoice.com/2019/12/'> December 2019</option><option value='https://mendovoice.com/2019/11/'> November 2019</option><option value='https://mendovoice.com/2019/10/'> October 2019</option><option value='https://mendovoice.com/2019/09/'> September 2019</option><option value='https://mendovoice.com/2019/08/'> August 2019</option><option value='https://mendovoice.com/2019/07/'> July 2019</option><option value='https://mendovoice.com/2019/06/'> June 2019</option><option value='https://mendovoice.com/2019/05/'> May 2019</option><option value='https://mendovoice.com/2019/04/'> April 2019</option><option value='https://mendovoice.com/2019/03/'> March 2019</option><option value='https://mendovoice.com/2019/02/'> February 2019</option><option value='https://mendovoice.com/2019/01/'> January 2019</option><option value='https://mendovoice.com/2018/12/'> December 2018</option><option value='https://mendovoice.com/2018/11/'> November 2018</option><option value='https://mendovoice.com/2018/10/'> October 2018</option><option value='https://mendovoice.com/2018/09/'> September 2018</option><option value='https://mendovoice.com/2018/08/'> August 2018</option><option value='https://mendovoice.com/2018/07/'> July 2018</option><option value='https://mendovoice.com/2018/06/'> June 2018</option><option value='https://mendovoice.com/2018/05/'> May 2018</option><option value='https://mendovoice.com/2018/04/'> April 2018</option><option value='https://mendovoice.com/2018/03/'> March 2018</option><option value='https://mendovoice.com/2018/02/'> February 2018</option><option value='https://mendovoice.com/2018/01/'> January 2018</option><option value='https://mendovoice.com/2017/12/'> December 2017</option><option value='https://mendovoice.com/2017/11/'> November 2017</option><option value='https://mendovoice.com/2017/10/'> October 2017</option><option value='https://mendovoice.com/2017/09/'> September 2017</option><option value='https://mendovoice.com/2017/08/'> August 2017</option><option value='https://mendovoice.com/2017/07/'> July 2017</option><option value='https://mendovoice.com/2017/06/'> June 2017</option><option value='https://mendovoice.com/2017/05/'> May 2017</option><option value='https://mendovoice.com/2017/04/'> April 2017</option><option value='https://mendovoice.com/2017/03/'> March 2017</option><option value='https://mendovoice.com/2017/02/'> February 2017</option><option value='https://mendovoice.com/2017/01/'> January 2017</option><option value='https://mendovoice.com/2016/12/'> December 2016</option><option value='https://mendovoice.com/2016/11/'> November 2016</option><option value='https://mendovoice.com/2016/10/'> October 2016</option><option value='https://mendovoice.com/2016/09/'> September 2016</option></select> <script type="text/javascript">/*  */
(function() {
	var dropdown = document.getElementById( "archives-dropdown--1" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/*  */</script> </div></div></div><div id="boilerplate"><div class="row-fluid clearfix"><div class="span6"><ul id="footer-social" class="social-icons"><li><a href="https://www.facebook.com/MendoVoice/" title="Link to Facebook Profile"><i class="icon-facebook"></i></a></li><li><a href="https://twitter.com/themendovoice" title="Link to Twitter Page"><i class="icon-twitter"></i></a></li><li><a href="https://www.youtube.com/channel/UCPLFjE2By4eiUwyRRkt5gRw" title="Link to YouTube Page"><i class="icon-youtube"></i></a></li><li><a href="https://www.instagram.com/mendovoice/" title="Link to Instagram Page"><i class="icon-instagram"></i></a></li><li><a href="https://mendovoice.com/feed/" title="Link to RSS Feed"><i class="icon-rss"></i></a></li></ul><div class="footer-bottom clearfix"><!-- If you enjoy this theme and use it on a production site we would appreciate it if you would leave the credit in place. Thanks :) --><p class="footer-credit">&copy; Copyright 2020, The Mendocino Voice, Mendocino News Media LLC</p><ul id="menu-footer-bottom" class="menu"><li id="menu-item-149319" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149319"><a href="https://mendovoice.com/about/">About Us</a></li><li id="menu-item-149320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149320"><a href="https://mendovoice.com/about/">Contact</a></li><li id="menu-item-149321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149321"><a href="https://mendovoice.com/tips/">Tips</a></li><li id="menu-item-149322" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-149322"><a href="https://mendovoice.com/advertise/">Advertise</a></li><li id="menu-item-156626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156626"><a href="https://mendovoice.com/commenting-and-letter-to-editor-policy/">Commenting and Letters-to-Editor Policy</a></li><li id="menu-item-164845" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-164845"><a href="https://mendovoice.com/background/">Mendocino Voices — A Membership Project</a></li><li id="menu-item-444649" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444649"><a href="https://mendovoice.com/membership/">Become a member</a></li><li id="menu-item-453790" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453790"><a href="https://mendovoice.com/membership/subscribe/">Subscribe to our newsletters</a></li><li id="menu-item-501461" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-501461"><a href="https://mendovoice.com/electionforum2020/">Watch the Mendocino Co. election forums Oct. 5 &#038; 8</a></li></ul></div></div><div class="span6 right"><p class="footer-credit footer-credit-padding-inn-logo-missing">Built with the <a href="http://largoproject.org">Largo WordPress Theme</a> from the <a href="http://inn.org">Institute for Nonprofit News</a>.</p></div></div><p class="back-to-top visuallyhidden"><a href="#top">Back to top &uarr;</a></p></div></footer></div><!-- ngg_resource_manager_marker --><noscript><img src="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/tracker.php?pids=97|124|135|72|136|63|134|137|65|63|120|133|97|0" alt="" /></noscript><img class="lazyload" id="oio-pixel" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20210%20140%22%3E%3C/svg%3E' data-src="https://mendovoice.com/wp-content/plugins/oiopub-direct/modules/tracker/tracker.php?pids=97|124|135|72|136|63|134|137|65|63|120|133|97|0" alt="" /> <script type="text/template" id="tmpl-floating-social-buttons"><div class="largo-follow post-social clearfix"><span class="more-social-links">
	<a class="popover-toggle" href="#"><i class="icon-plus"></i><span class="hidden-phone">More</span></a>
	<span class="popover">
	<ul>
		<li><a href="https://mendovoice.com/prominence/homepage-featured/"><i class="icon-link"></i> <span>More on Homepage Featured</span></a></li>
<li><a href="https://mendovoice.com/prominence/homepage-featured/feed/"><i class="icon-rss"></i> <span>Subscribe to Homepage Featured</span></a></li>
	</ul>
	</span>
</span></div></script> <script type="text/javascript" id="floating-social-buttons-width-json">window.floating_social_buttons_width = {"min":"1400","max":"9999"}</script> <!-- Quantcast Tag --> <script type="text/javascript">var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-qdLCxQQhkacJk",
				source:"wp"
			});</script> <noscript><div style="display:none;"> <img  border="0" height="1" width="1" alt="Quantcast" data-src="//pixel.quantserve.com/pixel/p-qdLCxQQhkacJk.gif" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="//pixel.quantserve.com/pixel/p-qdLCxQQhkacJk.gif" border="0" height="1" width="1" alt="Quantcast"/></noscript></div> </noscript> <!-- End Quantcast tag --> <noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://mendovoice.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.7.8'></script><div id='pico-widget-container'></div><script type='text/javascript' id='fvm-footer-0-js-extra'>/*  */
var Largo = {"is_home":"","is_single":"1","sticky_nav_options":{"sticky_nav_display":true,"main_nav_hide_article":false,"nav_overflow_label":"More"}};
/*  */</script> <script defer src="https://mendovoice.com/wp-content/cache/autoptimize/js/autoptimize_a6aa04f555b58be5b2167ffb3fc88264.js"></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->